[e10s] "Context Search X" Add-on doesn't work with e10s

RESOLVED FIXED

Status

()

Firefox
Extension Compatibility
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: alreiten, Unassigned)

Tracking

({addon-compat})

35 Branch
x86_64
Windows 7
addon-compat
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140904030202

Steps to reproduce:

Enable e10s in about:config.
Install Content Search X Add-on
https://addons.mozilla.org/en-US/firefox/addon/context-search-x/?src=userprofile
Highlight some text on a webpage and right click.


Actual results:

Content Search X's menu does not show up in the right click menu.


Expected results:

A submenu should appear that allows one to select which search engine to search with.
(Reporter)

Updated

4 years ago
Component: Untriaged → Extension Compatibility
Hardware: x86 → x86_64
Blocks: 905436
Keywords: addon-compat

Comment 1

3 years ago
User agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

I could not replicate this bug. The Search X addon works for me with E10S enabled. I am able to highlight text and right click, giving me the search submenu. Do you have a screenshot to demonstrate this bug?
Flags: needinfo?(alreiten)
alreiten, can you still reproduce this problem? A number of Firefox bugs have been fixed that should improve add-on compatibility.

For others, here's a link to the addon on AMO:
https://addons.mozilla.org/en-US/firefox/addon/context-search-x
tracking-e10s: --- → +
Summary: [e10s] Context Search X Add-on doesn't work with e10s → [e10s] "Context Search X" Add-on doesn't work with e10s
(Reporter)

Comment 3

3 years ago
Created attachment 8515408 [details]
Context Search X.png

I tried testing this again, with another new profile, but the add-on submenu in the context menu is still not showing up for me.  See attachment.
Flags: needinfo?(alreiten)
limweizhong, are you the developer of the "Content Search X" add-on? This add-on seems to be broken with multiprocess Firefox (e10s). If you have any questions about e10s support, just drop by the #e10s IRC channel on irc.mozilla.org. MDN also has a good introduction:

https://developer.mozilla.org/en-US/Add-ons/Working_with_multiprocess_Firefox
Status: UNCONFIRMED → NEW
Ever confirmed: true
The developer has been contacted through AMO.

Comment 6

3 years ago
I think the issue is that I have a custom function getBrowserSelection that does not limit the length of the selected text. I see that the official getBrowserSelection now uses a function getFocusSync from BrowserUtils.jsm. How do I include that file, and what actually does this line do: "elt.syncHandler.getFocusedElementAndWindow()"?

Comment 7

3 years ago
The new version of the add-on attempts to solve the compatibility issue. Please help to verify this. Thank you.
alreiten: can you please test whether the latest Context Search X addon (version 0.4.6.18 on AMO) works for you with e10s?
Tested on Nightly and it works correctly.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.