Closed Bug 1063256 Opened 5 years ago Closed 5 years ago

Need new strings for "{{n]} selected", due to new UX

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86_64
Linux
defect
Not set

Tracking

(b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S4 (12sep)
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: tchevalier, Assigned: tchevalier)

Details

(Keywords: late-l10n)

Attachments

(1 file, 1 obsolete file)

The new UX in SMS makes more obvious the need of new strings for "{{n}} selected" in headers.

Let's say in my language "thread" is feminine while "message" is masculine. (No spoilers, it is)


The new flow to suppress threads/messages is:

Open contextual menu, tap on "Select threads" (feminine), select your threads, it shows "{{n}} selected" (masculine here because the string is shared), tap on Delete, it shows "Delete selected message threads?" (Feminine).

So it feels way more natural to have feminine all way long rather than feminine/masculine/feminine.
Oops, wrong PR, here's the right one.

Waiting for a green try before asking for review, I might have missed tests.
Assignee: nobody → tchevalier
Attachment #8484657 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Comment on attachment 8484663 [details]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23748/files

Fixed linter error, TBPL looks good otherwise.

Looks like Julien is on PTO, given the tight schedule (we need to land strings on 2.1 before string freeze on Friday 12th), Steve, any chance you can give it a quick look?
Attachment #8484663 - Flags: review?(schung)
Comment on attachment 8484663 [details]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23748/files

Steve seems to have reviews in queue.

Oleg, maybe you can help here? I'd like this one on 2.1, we need to land today or tomorrow.

Patch tested on Flame 2.2, btw.
Attachment #8484663 - Flags: review?(azasypkin)
Comment on attachment 8484663 [details]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23748/files

Sorry for the delay, it looks fine to me but I'm not familiar about the masculine/feminine rule in language. May I know how we translate {{n}} selected in feminine way? :)
Attachment #8484663 - Flags: review?(schung)
Attachment #8484663 - Flags: review?(azasypkin)
Attachment #8484663 - Flags: review+
Awesome, thanks Steve!

Sure, here's what we have in French:

If it's about a thread (feminine): 1 sélectionnée, 2 sélectionnées
If it's about a message (masculine: 1 sélectionné, 2 sélectionnés
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/a4057734a6171f9c0eec64fcb1601acec3c561d0
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
Comment on attachment 8484663 [details]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/23748/files

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): UX header update on 2.1
[User impact] if declined: Not fully natural experience while deleting threads/messages in some languages
[Testing completed]: 2.2 device with new strings localized in French
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: yes, 14 new strings
Attachment #8484663 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8484663 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
You need to log in before you can comment on or make changes to this bug.