Last Comment Bug 106336 - % cellspacing, cellpadding values should be treated as pixel values in quirks mode
: % cellspacing, cellpadding values should be treated as pixel values in quirks...
Status: VERIFIED FIXED
PATCH CANDIDATE_094
: testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: x86 Windows 2000
: P1 normal (vote)
: mozilla0.9.6
Assigned To: karnaze (gone)
: Amarendra Hanumanula
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 14:45 PDT by karnaze (gone)
Modified: 2001-10-26 16:12 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (103 bytes, text/html)
2001-10-24 14:48 PDT, karnaze (gone)
no flags Details
patch to fix the bug (3.70 KB, patch)
2001-10-24 14:49 PDT, karnaze (gone)
alexsavulov: review+
attinasi: superreview+
Details | Diff | Splinter Review

Description karnaze (gone) 2001-10-23 14:45:06 PDT
For compatibility reasons, % cellpadding, cellspacing values need to be treated 
as pixel values.

<table>
 <tr>
  <td>foo</td>
  <td>bar</td>
 </tr
</table>
Comment 1 karnaze (gone) 2001-10-23 14:46:38 PDT
add cellspacing=40% cellpadding=20%
Comment 2 karnaze (gone) 2001-10-24 14:48:40 PDT
Created attachment 54941 [details]
testcase
Comment 3 karnaze (gone) 2001-10-24 14:49:33 PDT
Created attachment 54942 [details] [diff] [review]
patch to fix the bug
Comment 4 Marc Attinasi 2001-10-24 15:42:59 PDT
Comment on attachment 54942 [details] [diff] [review]
patch to fix the bug

sr=attinasi
Comment 5 Alexandru Savulov 2001-10-24 15:56:47 PDT
Comment on attachment 54942 [details] [diff] [review]
patch to fix the bug

r= alexsavulov
Comment 6 karnaze (gone) 2001-10-24 17:31:04 PDT
The patch is in.
Comment 7 karnaze (gone) 2001-10-24 17:32:20 PDT
The patch turns % cellpadding values in standard mode into pixel values as well, 
since we don't correctly support % cellpadding yet.
Comment 8 Amarendra Hanumanula 2001-10-26 16:12:09 PDT
The patch did fix the bug.. Marking verifed

Note You need to log in before you can comment on or make changes to this bug.