Closed Bug 1063518 Opened 5 years ago Closed 5 years ago

"Learn More" link for the Mozilla Location Service is visible on Beta/Release despite MLS setting not available

Categories

(Firefox for Android :: Settings and Preferences, defect)

32 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 35
Tracking Status
firefox32 --- wontfix
firefox33 + verified
firefox34 + verified
firefox35 --- verified
fennec 33+ ---

People

(Reporter: lars, Assigned: Margaret)

References

Details

Attachments

(2 files)

In the Settings -> Mozilla section of FF Android Beta, there is a select box with the heading "Crash Reporter".  Immediately below that is a "Learn More" link.  Pressing that link take the user to a page about "Mozilla Location Service".

Either the "Learn More" link is missing a "Location Service" label or the link is erroneously going to "Location Service" instead of "Crash Reporter"  

ASUS Model K010; Android 4.4.2
Oh, that learn more link is for the 'Mozilla Location Service', which is an opt-in setting that appears under the 'Crash Reporter' setting. It is currently disabled on beta & release. We shouldn't be showing that link if the service is not enabled.
tracking-fennec: --- → ?
OS: Linux → Android
Hardware: x86_64 → ARM
Summary: settings -> Mozilla - "Learn More" under "Crash Reporter" goes to wrong place → "Learn More" link for the Mozilla Location Service is visible on Beta/Release despite MLS setting not available
Blocks: 903535
I just modeled this after what we already do for the health report learn more link. Oddly enough, there was already a PREFS_GEO_LEARN_MORE constant, but it was unused.
Assignee: nobody → margaret.leibovic
Attachment #8485678 - Flags: review?(liuche)
Attachment #8485678 - Flags: review?(liuche) → review+
Comment on attachment 8485678 [details] [diff] [review]
Hide MLS "Learn More" link when MLS is disabled

Approval Request Comment
[Feature/regressing bug #]: regression from bug 903535
[User impact if declined]: unrelated "Learn more" link appears under crash reporter preference
[Describe test coverage new/current, TBPL]: no tests
[Risks and why]: low-risk, adds check to hide MLS "Learn more" link when MLS preference is hidden
[String/UUID change made/needed]: none
Attachment #8485678 - Flags: approval-mozilla-beta?
Attachment #8485678 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/5071f4bd6109
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
tracking-fennec: ? → 33+
Comment on attachment 8485678 [details] [diff] [review]
Hide MLS "Learn More" link when MLS is disabled

Looks simple enough and it's good to clean this up. Beta+ and Aurora+
Attachment #8485678 - Flags: approval-mozilla-beta?
Attachment #8485678 - Flags: approval-mozilla-beta+
Attachment #8485678 - Flags: approval-mozilla-aurora?
Attachment #8485678 - Flags: approval-mozilla-aurora+
Verified as fixed on Firefox 33 Beta 4 on Samsung Galaxy Nexus (Android 4.2.1)
Verified as fixed on
Build: Firefox for Android 34 Beta 1
Device: Asus Transformer Pad TF300T (Android 4.2.1)
On Firefox for Android 35 Beta 1 build 2, 'Mozilla Location Service' setting is displayed under the 'Crash Reporter' setting. Isn't this service disabled on Beta and release?
(In reply to Cristina Madaras, QA [:CristinaM] from comment #10)
> On Firefox for Android 35 Beta 1 build 2, 'Mozilla Location Service' setting
> is displayed under the 'Crash Reporter' setting. Isn't this service disabled
> on Beta and release?

Since MLS is available again, 'Mozilla Location Service' setting and 'Learn more' link are correctly displayed. I will mark this as Verified fixed.
Status: RESOLVED → VERIFIED
(In reply to Cristina Madaras, QA [:CristinaM] from comment #10)
> On Firefox for Android 35 Beta 1 build 2, 'Mozilla Location Service' setting
> is displayed under the 'Crash Reporter' setting. Isn't this service disabled
> on Beta and release?

No, it's shipping in Firefox 35 beta: https://www-dev.allizom.org/en-US/mobile/35.0beta/releasenotes/
You need to log in before you can comment on or make changes to this bug.