Closed Bug 106357 Opened 18 years ago Closed 9 years ago

reduce number of memory allocation in XML parser

Categories

(Core :: XML, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 291643
Future

People

(Reporter: cathleennscp, Assigned: hjtoi-bugzilla)

References

Details

(Keywords: memory-footprint)

trace-malloc results for mozilla startup, with blank page

Type                    Count    Bytes %Total
TOTAL                  115396  5863421 100.00
void*                   23517   943767  16.10
registry-Buffer             1   512000   8.73
xpti-unclassified         250   274080   4.67
unclassified-string      5623   203441   3.47
JSScopeProperty          4460   160560   2.74
gtk-unclassified          928   159473   2.72
nsZipArchive             3438   147662   2.52
JS-Array                 4654   144448   2.46
js_MatchToken            5046   135536   2.31
FrameArena                 31   127565   2.18
JS-script                 866   125423   2.14
nsXULElement             2086   118296   2.02
JS-atom                  4085   114218   1.95
CSSDeclarationImpl       2732   109940   1.88
nsCSSRule                1342   106488   1.82
JSScope                  1140    95760   1.63
nsComponentManagerImpl   2312    90464   1.54
nsTextFragment            360    90106   1.54
JS-unclassified          2110    87392   1.49
nsStaticCaseInsensitiveNameTable   2574    85184   1.45
orkin-unclassified         50    82694   1.41
X-unclassified           3187    82483   1.41
nsCStringKey             2525    77323   1.32
JS-GC-arena                 8    73912   1.26
JS-function              2412    71840   1.23
nsXULAttribute              5    71680   1.22
AtomImpl                 1749    65758   1.12
nsXULAttributes           865    62280   1.06
xptiInterfaceInfo        1409    62232   1.06
nsXMLElement             1137    59124   1.01
RuleHash                 3782    58652   1.00
InMemoryDataSource         92    56074   0.96
nsPersistentProperties   1923    55962   0.95
sscanf                   1504    55325   0.94
xptiManifest             1874    46336   0.79
JS-slots                  818    45536   0.78
nsImageGTK                110    44008   0.75
nsXULPrototypeElement     891    42768   0.73
nsSupportsArray           582    32592   0.56
OTHER                   22918   885039  15.09
XML --> heikki
Assignee: harishd → heikki
Heikki, can you look into reducing memory allocation in XML for 0.9.7?
Target Milestone: --- → mozilla0.9.7
Status: NEW → ASSIGNED
Priority: -- → P2
What does trace-malloc show now that hyatt has decoupled XBL elements from XML
elements?
Target Milestone: mozilla0.9.7 → mozilla0.9.9
Priority: P2 → --
Target Milestone: mozilla0.9.9 → ---
Target Milestone: --- → Future
QA Contact: petersen → rakeshmishra
I noticed a similar problem -- loading a 3mb XML file (download and decompress 
ftp://beta.rcsb.org/pub/pdb/uniformity/data/XML/all/1tim.xml.gz) in Mozilla 
1.4 RC3 on Windows XP sucks up 275MB of memory and takes a non-trivial time 
interval (this on a 3GHz P4) before displaying the file. 
QA Contact: rakeshmishra → ashishbhatt
QA Contact: ashshbhatt → xml
Blocks: mslim-fx5+
Forwarding-dup'ing this with 291643 because that bug has lots of good analysis about the problem.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 291643
You need to log in before you can comment on or make changes to this bug.