Closed Bug 1063842 Opened 5 years ago Closed 5 years ago

Add in-product notification when e10s is first enabled

Categories

(Firefox :: General, defect)

defect
Not set
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 35
Iteration:
35.1
Tracking Status
e10s m2+ ---

People

(Reporter: cpeterson, Assigned: Felipe)

References

Details

(Whiteboard: [e10s-m2])

Attachments

(2 files)

We want to warn Nightly users that stuff will break and how to disable e10s.
Depends on: 1058358
Flags: firefox-backlog+
Flags: qe-verify?
Assignee: nobody → felipc
Status: NEW → ASSIGNED
Hi Felipe, can you provide a point value and mark the bug as qe-verify or qe-verify-.
Iteration: --- → 35.1
Flags: needinfo?(felipc)
This bug should be fixed for the e10s M2 milestone.
I think you'll want a global notification bar here, not a doorhanger. The latter is tab-specific, and should only be used for things relevant to the site in the tab. We already have the global notification bar for things like Sync errors, and slow-startup notices.
Summary: Add in-product notification when e10s is first enabled (use door hanger with opt-out button?) → Add in-product notification when e10s is first enabled
Yes, a notification bar seems like the right mechanism here.
Given that users actively opt into this, we can even use the one at the top of the window.

I'm assuming that the bar would contain something like:
»Thanks for helping test multiprocess Firefox (e10s). Some functions might not work yet. Learn more«
With just one [x] button.

Will we have any opt-out mechanism for e10s or will it only be accessible via about:config?
Points: --- → 3
Flags: qe-verify?
Flags: qe-verify+
Flags: needinfo?(felipc)
Attached image e10s notice.png
This is what the current patch looks like. The Learn More button takes the https://wiki.mozilla.org/Electrolysis, the same link as from bug 1064885

(In reply to Philipp Sackl [:phlsa] from comment #4)
> Will we have any opt-out mechanism for e10s or will it only be accessible
> via about:config?

There will also be the checkbox in the preferences pane that Gavin is adding on bug 1064886
Attached patch PatchSplinter Review
Attachment #8487455 - Flags: review?(mconley)
Comment on attachment 8487455 [details] [diff] [review]
Patch

Review of attachment 8487455 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/nsBrowserGlue.js
@@ +2252,5 @@
> +  // e10s testing period to Nightly users.
> +  CURRENT_NOTICE_COUNT: 1,
> +
> +  checkStatus: function() {
> +    if (Services.appinfo.browserTabsRemoteAutostart) {

A quick DXR doesn't show this being defined anywhere... what patch is supposed to make this available?
Attachment #8487455 - Flags: review?(mconley)
It's in inbound! Bug 1063848
Note: I shall move the checkStatus call from _onFirstWindowLoaded to _onWindowsRestored
Comment on attachment 8487455 [details] [diff] [review]
Patch

Review of attachment 8487455 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thanks Felipe!

::: browser/components/nsBrowserGlue.js
@@ +2273,5 @@
> +
> +    Services.prefs.setIntPref("browser.displayedE10SNotice", this.CURRENT_NOTICE_COUNT);
> +
> +    let nb = win.document.getElementById("high-priority-global-notificationbox");
> +    let message = "Thanks for helping test multiprocess Firefox (e10s). Some functions might not work yet."

I think this should probably be:

"Thanks for helping to test multi-process Firefox (e10s). Some functions might not work yet."
Attachment #8487455 - Flags: review+
I changed the string as you suggested, and also took the liberty to do a small change in the patch such that setting the COUNT to 0 will make it not display this notification. With that, we can control when we want to start displaying this (rather than "tomorrow"), by just increasing changing that value to 1.

https://hg.mozilla.org/integration/mozilla-inbound/rev/bbbe6b294206
https://hg.mozilla.org/mozilla-central/rev/bbbe6b294206
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
For QE: To test this properly, set the following prefs:
browser.tabs.remote.autostart => true
browser.displayedE10SNotice => -1
I updated the wiki to speak more to testers landing from the opt-in door hanger's "Learn More" link:

https://wiki.mozilla.org/Electrolysis
Duplicate of this bug: 1063672
QA Contact: jbecerra
I tested multiple scenarios on all platforms using latest Nightly the notification for when e10s is first enabled, no issue was found. Marking this bug as verified fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.