Casting video is disabled on Beta

VERIFIED FIXED in Firefox 33

Status

()

Firefox for Android
Screencasting
VERIFIED FIXED
3 years ago
a year ago

People

(Reporter: mfinkle, Assigned: mfinkle)

Tracking

Trunk
Firefox 35
All
Android
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox33 verified, firefox34 verified, firefox35 verified, fennec33+)

Details

Attachments

(1 attachment)

Created attachment 8485370 [details] [diff] [review]
enable-casting v0.1

We never removed the build flag:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/app/mobile.js#285

We'll need to make a new beta at the earliest possible time.

This simple, low risk patch needs to be uplifted to aurora and beta.
Attachment #8485370 - Flags: review?(rnewman)
Attachment #8485370 - Flags: approval-mozilla-beta?
Attachment #8485370 - Flags: approval-mozilla-aurora?
Attachment #8485370 - Flags: review?(rnewman) → review+
Checkin-needed for m-c, even though it won't have a visible effect there.
Assignee: nobody → mark.finkle
Status: NEW → ASSIGNED
Keywords: checkin-needed
OS: Linux → Android
Hardware: x86_64 → All
tracking-fennec: --- → 33+
status-firefox33: --- → affected
status-firefox34: --- → affected
status-firefox35: --- → affected
https://hg.mozilla.org/integration/fx-team/rev/b875e1449d67
I was landing something anyway, so bombs away.
Keywords: checkin-needed
Comment on attachment 8485370 [details] [diff] [review]
enable-casting v0.1

This has no real change for Aurora, but needs to ride the trains. Enabling for Beta was the expectation of everyone (Product, Dev, QA, etc) so I am approving to make sure we get this in the the next Beta build with all due haste.
Attachment #8485370 - Flags: approval-mozilla-beta?
Attachment #8485370 - Flags: approval-mozilla-beta+
Attachment #8485370 - Flags: approval-mozilla-aurora?
Attachment #8485370 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/2fd01375c79f
https://hg.mozilla.org/releases/mozilla-beta/rev/32560f800b2e
status-firefox33: affected → fixed
status-firefox34: affected → fixed
Anything else in screen-casting behind a #ifdef RELEASE_BUILD that shouldn't?
Nothing unexpected. We use this only other one to change the name of the expected Roku app:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/modules/RokuApp.jsm#27

We have one Roku app for Nightly/Aurora and a different one for Beta/Release.
https://hg.mozilla.org/mozilla-central/rev/b875e1449d67
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35

Updated

3 years ago
Flags: qe-verify+
status-firefox35: affected → fixed

Comment 9

3 years ago
Verified as fixed in builds:
- 35.0a1 (2014-09-08);
- 34.0a1 (2014-09-08);
- 33 beta 2;
Device: Google Nexus 7 (Android 4.4.4).
Status: RESOLVED → VERIFIED
status-firefox33: fixed → verified
status-firefox34: fixed → verified
status-firefox35: fixed → verified
Duplicate of this bug: 1063956
You need to log in before you can comment on or make changes to this bug.