Closed Bug 1063896 Opened 5 years ago Closed 5 years ago

Regression: missing thumbnails in top sites; thumbnails replaced with tiny Favicons

Categories

(Firefox for Android :: General, defect)

34 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 35
Tracking Status
firefox32 --- unaffected
firefox33 + fixed
firefox34 + fixed
firefox35 + verified
fennec 33+ ---

People

(Reporter: micmon, Assigned: wesj)

References

Details

(Keywords: regression, reproducible)

Attachments

(3 files)

When I switched to Aurora 33, all my "top sites" thumbs were replaced by small site icons. At the time I thought this was a feature. Now, on Aurora 34, one of the sites again has a thumb but the other five do not which looks strange.

I found similar bugs like #756881 but they all seem to be fixed in Aurora 34.
Here's a screenshot. The page that now works again is

http://www.androidpolice.com/

The pages that still do not show a thumb are

http://blog.fefe.de/
http://www.spiegel.de/
http://phandroid.com/
http://androidandme.com/
http://worldofgnome.org/
The above report is about Firefox on my Nexus 5. On my Nexus 7 the thumbs also disappears but even after updating to Aurora 34 the Androidpolice thumb is still gone.
Do the thumbnails come back when you visit the site?

When you visit those sites, do they redirect to a mobile version or a different URL? E.g., adding https, m. prefix, etc.
>> Do the thumbnails come back when you visit the site?

No, I visited all the pages a number of times but still only androidpolice shows the thumb.

>> When you visit those sites, do they redirect to a mobile version or a different URL?

No, some of them (not all) show a mobile layout but the URL stays the same.
tracking-fennec: --- → ?
wesj, maybe this is related to the work you've done around site images?
Flags: needinfo?(wjohnston)
Assignee: nobody → wjohnston
tracking-fennec: ? → 34+
Duplicate of this bug: 1066343
According to the dupe above, on update from 32 to 33 all items in top-sites were replaced with generic globe icons
Summary: Missing thumbs in top sites → Missing thumbnails in top sites
[Tracking Requested - why for this release]: Regression
tracking-fennec: 34+ → 33+
Findings

'Small Favicon' instead of the site thumbnail issue

  Load http://androidpolice.com
  Check on about:home, see tiny Favicon instead of site thumbnail (akin to the open tab in the drawer)

Last good revision: 869971ad9fd6 (2014-07-16)
First bad revision: a74600665875 (2014-07-17)

Pushlog:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=869971ad9fd6&tochange=a74600665875

Which yields us: 

0814bb0f08d0	Wes Johnston — Bug 1014712 - Store ms tile image information for showing on about:home. r=rnewman,lucasr

I'm not sure if this is also causing the Globe issue too.
Blocks: 1014712
Summary: Missing thumbnails in top sites → Regression: missing thumbnails in top sites; thumbnails replaced with tiny Favicons
Status: NEW → ASSIGNED
Keywords: reproducible
Attached patch PatchSplinter Review
This was dumbness on my part. We're looping over only the urls that our metadata table returned instead of over all of our requested urls. That means that urls where nothing was returned are basically ignored and wind up falling back to their favicon.

This loops over all the urls.
Attachment #8489694 - Flags: review?(lucasr.at.mozilla)
Flags: needinfo?(wjohnston)
Comment on attachment 8489694 [details] [diff] [review]
Patch

Review of attachment 8489694 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch.
Attachment #8489694 - Flags: review?(lucasr.at.mozilla) → review+
Comment on attachment 8489694 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1014712
[User impact if declined]: thumbnails aren't shown even though we have them. We always wind up showing favicons that look awful
[Describe test coverage new/current, TBPL]: none :(
[Risks and why]: Pretty low risk. The loops here already have fallbacks in place for things without metadata, we just weren't hitting it as often as we should.
[String/UUID change made/needed]: none.
Attachment #8489694 - Flags: approval-mozilla-beta?
Attachment #8489694 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/2494d16f6cae
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Attachment #8489694 - Flags: approval-mozilla-beta?
Attachment #8489694 - Flags: approval-mozilla-beta+
Attachment #8489694 - Flags: approval-mozilla-aurora?
Attachment #8489694 - Flags: approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
I can confirm that after the fix landed all but one thumb appeared. For one page (http://www.spiegel.de/) I only see white with one thin vertical line. Should I file a new bug?
I don't see that. Using Firefox Nighty or Beta. On http://www.spiegel.de/ or their mobile site.
This is how it looks for me. I removed and re-added the page, still the same.
You need to log in before you can comment on or make changes to this bug.