Closed Bug 1064001 Opened 6 years ago Closed 6 years ago

auto form populated in the wrong order.

Categories

(Toolkit :: Autocomplete, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 286933

People

(Reporter: joshhua123, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140716183446

Steps to reproduce:

When you have your user details saved and start typing your account details to log into a website, you get the auto form. So you press down to select which one to enter and press enter to select it, but a website also can use the enter to trigger the submit. so the fields get populated and then submitted, but in the wrong order. so the form is sent and then your fields are populated. The website will say you've entered the wrong details.


Actual results:

The login fails and returns the form back to the state it was in before you pressed enter.


Expected results:

The form should of been populated and then submitted so the log in is successful.
Summary: auto form → auto form populated in the wrong order.
Reporter, could you please point to a site of that kind? Couldn't reproduce this issue on Facebook, Twitter nor Linkedin with Firefox 31 RC build 2 (Build ID: 20140716183446) and latest Nightly 2014-09-07.
Flags: needinfo?(joshhua123)
http://www.ecu.edu.au/ at the top right click on student/staff portal and that's the log in site where this occurs.
Flags: needinfo?(joshhua123)
Joshhua, many thanks for providing the URL.
I was able to reproduce this issue with Firefox 32 RC (Build ID: 20140825202822) latest Nightly 2014-09-07 on Windows 7 64-bit and Mac OS X 10.9.4.
Also reproducible with Firefox 4.0.1 RC (Buidl ID: 20110413222027) - not a regression.
Not reproducible with Chrome.
Status: UNCONFIRMED → NEW
Component: Untriaged → Autocomplete
Ever confirmed: true
OS: Windows 8.1 → All
Product: Firefox → Toolkit
Hardware: x86_64 → All
Version: 31 Branch → Trunk
This is basically because the web form has a keypress event listener on the input box that submits the form. Possible duplicates:

bug 175597
bug 286933
bug 364733
bug 819616

Picking 286933 because it's the oldest and still open.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286933
You need to log in before you can comment on or make changes to this bug.