The URL displayed under tab titles in the Synced Tabs panel disappears for a while after choosing "Open in New Tab"/"Open in Private Tab"

VERIFIED FIXED

Status

()

VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: TeoVermesan, Assigned: nalexander)

Tracking

({reproducible})

35 Branch
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox35 affected, fennec35+)

Details

(Reporter)

Description

4 years ago
Tested with:
Devices: Samsung Galaxy S5 (Android 4.4.2), LG Nexus 4 (Android 4.4.2)
Build: Firefox for Android 35.0a1 (2014-09-07)

Steps to reproduce:
1. Perform sync on your device
2. Go to the Synced Tabs panel and long tap on a page
3. Choose "Open in New Tab"/"Open in Private Tab"

Expected results:
- The panel is displayed with the name of the page and the URL under it. 

Actual results:
- The URL under the page disappears for a few seconds and after that appears.

Please see the following video:
https://www.youtube.com/watch?v=OhE4nhaRGao
I see this too (Nightly 09/08).
Blocks: 1014994
tracking-fennec: --- → ?
Keywords: reproducible
Summary: The URL displayed under the page in Synced Tabs disappears for a while when choosing "Open in New Tab"/"Open in Private Tab" → The URL displayed under tab titles in the Synced Tabs panel disappears for a while after choosing "Open in New Tab"/"Open in Private Tab"
Fascinating.  Thanks for the report, folks.
I believe this is a race condition with TwoLinePageRow (incorrectly) updating the page URL in response to certain tab events.  It should be fixed by Bug 977164, which hooks the PageRows into the Remote Tabs panel update flow more properly.
Assignee: nobody → nalexander
tracking-fennec: ? → 35+
Status: NEW → ASSIGNED
I expect this is fixed.  AaronMT, should I close this ticket, or should I wait for QA to verify that it is fixed?
Let's check with Teodora
Flags: needinfo?(teodora.vermesan)
(Reporter)

Comment 6

4 years ago
I am not able to reproduce the issue on Samsung Galaxy S5 (Android 4.4.2) on latest Nightly (29-09-2014).
Flags: needinfo?(teodora.vermesan)
Great. Fixed via bug 977164
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

4 years ago
Opening a tab from synced tabs in new tab, under it, it's displayed "switch to tab" and opening in new private tab, the URL under it doesn't disappears anymore.
So marking this bug as VERIFIED FIXED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.