Closed Bug 1064234 Opened 5 years ago Closed 5 years ago

[Contacts] When ICE contact's name is long, Setting menu isn't correctly visible

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S4 (12sep)
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: lolimartinezcr, Assigned: arcturus)

References

Details

Attachments

(4 files)

Flame
2.1
Gecko-8a9db5d
Gaia-a8e4d26

Reproducible: 100%

STRs:
1. Tap contacts application.
2. Tap Settings button.
3. Tap "Set ICE Contacts" button.

Actual result:
It isn't correctly visible. See attached image.

Expected result:
It is correctly visible.
Attached image 2014-09-08-14-27-29.png
Good catch :) thanks!
Blocks: 1042577
No longer blocks: 1038701
[Blocking Requested - why for this release]: Broken UI
blocking-b2g: --- → 2.1?
Attached file Pointer to PR 23823
Attachment #8485994 - Flags: review?(sergi.mansilla)
Comment on attachment 8485994 [details] [review]
Pointer to PR 23823

Just a small comment in the PR, but r+ to me. Thanks Francisco!
Attachment #8485994 - Flags: review?(sergi.mansilla) → review+
Assignee: nobody → francisco
Status: NEW → ASSIGNED
triage: not blocking since it's not very common to have such a long name.
We still want it to be fixed in 2.1 if the approval can be given.
blocking-b2g: 2.1? → backlog
Forgot to mark as fixed :S
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Tested and working
2.1
Gecko-52f8689
Gaia-d61264c
(In reply to Loli (:lolimartinezcr) from comment #9)
> Tested and working
> 2.1
> Gecko-52f8689
> Gaia-d61264c

Although the patch has not uploaded  to 2.1, it's working
wow, that doesnt make much sense.

I've tried this in 2.2 (master) and it's working, also in 2.1 it's not working.

Loli can you try again?
Flags: needinfo?(lolimartinezcr)
Attached image 2014-09-11-13-10-49.png
Flags: needinfo?(lolimartinezcr)
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #11)
> wow, that doesnt make much sense.
> 
> I've tried this in 2.2 (master) and it's working, also in 2.1 it's not
> working.
> 
> Loli can you try again?
OK, not problem i try to test again
(In reply to Loli (:lolimartinezcr) from comment #13)
> (In reply to Francisco Jordano [:arcturus] [:francisco] from comment #11)
> > wow, that doesnt make much sense.
> > 
> > I've tried this in 2.2 (master) and it's working, also in 2.1 it's not
> > working.
> > 
> > Loli can you try again?
> OK, not problem i try to test again

I have tested again with last version in 2.1 and *not working*. Last day I saw it working because it depends of incoming string in name 2014-09-11-13-10-49.png, but if i write other string it isn't working.
Thanks Loli! Francisco, can you ask for the approval?

Adding it to the meta bug 1026943
Blocks: comms_2.1
Flags: needinfo?(francisco)
Tested and working
Flame
2.2
Gecko-713c41b
Gaia-32d82d2
Comment on attachment 8485994 [details] [review]
Pointer to PR 23823

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Feature ICE
[User impact] if declined:
Bad user experience with long names, especially on countries like south america
[Testing completed]:
Test passed by QA
[Risk to taking this patch] (and alternatives if risky):
Low risk, small change in the ui to prevent the ugly effect
[String changes made]:
Attachment #8485994 - Flags: approval-gaia-v2.1?(bbajaj)
Flags: needinfo?(francisco)
Attachment #8485994 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
Tested and working
Flame
2.1
Gecko:3953700
Gaia:713448b
Status: RESOLVED → VERIFIED
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.