Closed Bug 1064256 Opened 5 years ago Closed 5 years ago

[Contacts] "TypeError: iceGroup is null"

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

defect
Not set

Tracking

(b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S4 (12sep)
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: arcturus, Assigned: arcturus)

Details

(Whiteboard: [p=1])

Attachments

(2 files)

We get this error when we don't have any contact set as ICE.

Easily reproducible when doing a make reset-gaia
Assignee: nobody → francisco
Whiteboard: [p=1]
Attached file Pointer to PR 23805
Attachment #8485714 - Flags: review?(sergi.mansilla)
Comment on attachment 8485714 [details] [review]
Pointer to PR 23805

Thanks Francisco! r+
Attachment #8485714 - Flags: review?(sergi.mansilla) → review+
Comment on attachment 8485714 [details] [review]
Pointer to PR 23805

Hei Zac,

had to modify the python ui tests, since we are creating now a new 'hidden' contact always that will lead us to the ICE section, when where selecting the number of contacts we were always having an extra one.

Just modify the selector to avoid including this hidden new row in the contact list.
Attachment #8485714 - Flags: review?(zcampbell)
Attachment #8485714 - Flags: review?(zcampbell) → review+
Comment on attachment 8485714 [details] [review]
Pointer to PR 23805

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
ICE feature
[User impact] if declined:
We have a constant javascript error that can lead to major disfunction
[Testing completed]:
Smoke test, and more unit tests added to check this problem
[Risk to taking this patch] (and alternatives if risky):
Low, patchi is moving some lines above, and more unit test than proper patch
[String changes made]:
Attachment #8485714 - Flags: approval-gaia-v2.1?(bbajaj)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8485714 [details] [review]
Pointer to PR 23805

Approving the landing as the risk looks manageable at this point in the release cycle and given the added test
Attachment #8485714 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
Hi Ryan,

something must have changed in our test harness, cause this was a problem on reseting the status of tests.

I just did a patch for 2.1, this patch compared with 2.2 has a line different, doing that reset automatically.

Could you uplift that one?

Thanks!
Flags: needinfo?(francisco) → needinfo?(ryanvm)
I can't get this patch to apply. Can you just submit a pull request?
Flags: needinfo?(ryanvm) → needinfo?(francisco)
Will do,

Thanks!
Flags: needinfo?(francisco)
Unfortunately will need to backout last commit. As was the same that was merged originaly and producing the error in unit tests:


941cc6c93a64875bf88eb38d7327fb35db0a6ae2
You need to log in before you can comment on or make changes to this bug.