[Facebook] Check/uncheck buttons do not work properly

RESOLVED WONTFIX

Status

Tech Evangelism
Preinstalled B2G Apps
P2
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: joseenrique.alvarezfernandez, Assigned: Michael Ellis)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [6830])

(Reporter)

Description

3 years ago
Tested on a OPENC and SORA devices with 1.3

Description: When you select See Friends Lists on one of the friends in the list, the check/uncheck buttons for Close Friends and Acquaintances stop working after the second tap on them, and you cannot toggle their value anymore.

Steps to reproduce:
- Open facebook app
- Open you FB profile
- TAp on the Friend button
- Select one of your friend by tapping on it
- Tap in the icon right to he name of your friend  and then tap on See Friends Lists
- Tap on any of the options that you can see there that are different from the current one of your friend.
- Tap on the previous option of your friendship
- Tap on any other of the options available there and you'll see that it's not changing anymore
(Assignee)

Comment 1

3 years ago
Per Facebook’s req:

Open bugs should be forwarded to Fb’s new internal bug tracking system. Following their guidelines, all current unassigned bugs will be placed into a single spreadsheet and sent over to Fb’s new system.  Michael Ellis will be the assignee for these bugs and will update each as feedback is received from Fb.
Assignee: colby → mellis
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 2

3 years ago
Hi all

With the latest FB update there is something different happening.
Steps to reproduce:
- Open facebook app
- Open you FB profile
- TAp on the Friends button
- Select one of your friend by tapping on it
- Tap in the icon right to he name of your friend  and then tap on See Friends Lists
- Tap on any of the options that you can see there that are different from the current one of your friend. This will make a tick mark to appear. 
- Tap on the same option. The tick mark will not disappear as expected
- Tap on back arrow and the on the forward arrow (go back and then return to the page)
- Now you are able to uncheck the option you've previously selected

I don't know if this is intended or not. @Michael could you please confirm?
Flags: needinfo?(mellis)
(Assignee)

Comment 3

3 years ago
Jose - Issue is confirmed as you reported it on both 2.0 and 1.3.  
This flow is not intended, as the user (seemingly) can only change the setting once per page-load. Expected result is a seemless toggle back and forth when option is selected.

We will try to repro this on other Browsers this afternoon.
Flags: needinfo?(mellis)
(Assignee)

Comment 4

3 years ago
Because this bug is a lower priority, and the user can change the setting by reloading the page, let's not use one of our "wildcards" for the fb team on this.

Rather, we can report the issue through Fb's internal user-reporting channel.

Please let me know if you disagree..
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(joseenrique.alvarezfernandez)
Resolution: --- → WONTFIX
Whiteboard: [6830]
(Assignee)

Comment 5

3 years ago
Reconsidering, there is another bug caused by the same issue (Bug 1088563)  Changing this to p2, reopening, and adding to shortlist; let's discuss during meeting.
Depends on: 1088563
Priority: P3 → P2
(Assignee)

Comment 6

3 years ago
Bug 1064981 is the similar bug I intended to reference above.
Depends on: 1064981
No longer depends on: 1088563
(Reporter)

Comment 7

3 years ago
Hi Michael

Let's discuss it over our call. Although it may not be the most used feature on mobile, I believe that at least we should tell FB.
There is a workaround though: just tap on the back arrow and then in the ahead arrow and you'll be able to change it.
Seems that the page only allows one change of state per visit to the page
Flags: needinfo?(joseenrique.alvarezfernandez)
(Assignee)

Comment 8

3 years ago
Perhaps this would be a good candidate for A/B testing? We could include this, with a few other P3/P4's to see if facebook is really addressing the bugs we are communicating.  (ie: send 3 bugs & also don't send 3 bugs, then monitor all six bugs for resolutions)
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 9

2 years ago
Received word from the partner that this bug is a Wont Fix 

"Below issue is closed as "Won't fix" because this is mozilla device only and the functionality works after refresh so this is not too terrible."
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.