selection includes cr/lf

VERIFIED DUPLICATE of bug 98572

Status

VERIFIED DUPLICATE of bug 98572
17 years ago
13 years ago

People

(Reporter: ddw, Assigned: mozeditor)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

Sorry about the following vague problem description.

First noticed in the email editor then subsequently in the composer editor when
one is attempting to edit existing text (meaning only that one has moved back to
a certain text selection entered possibly moments before).  The text selection
may wrap from the end of a sentence down past the next LF (not visible but
presumably there) and possibly down another line or two when some lesser
selection is desired.  IOW, the editor presumes I want more in the selection
than I intended to select.

It happens frequently at the end of email compositions when I attempt to  select
and eliminate the extra blank lines at the below the last text before the tag
line starting with the double dash (ie '--' ).  IOW, I seem unable to select
just a portion of the blank space to say remove two out of five blank lines at
the end of the email.  

This seems to occur when selecting text with my mouse then some combination of
Control & 'X', 'C' , or 'V' 

Reproducible: Sometimes
Steps to Reproduce:
1.as above
2.
3.

Actual Results:  see description

Expected Results:  I expect the ditor to select only what I have 'described'
with the mouse and not automagically more.

Sorry again for being so vague but others must have experienced peculiar
behavior from these editors.  

Please confirm that the editors for composer and email composing are the same?

Comment 1

17 years ago
Sorry David, but this is not a valid bug report. You need to follow
the bug writing guidelines....Please list precise steps to recreate
the problem. We need reproducible steps so we can track down the problem.

What you described below is kind of vague.

Comment 2

17 years ago
Kathy says here that the problem is that users can't see where
the cr/lf are....

assign to Joe.
Assignee: syd → jfrancis
Summary: composer & email editor problems → selection includes cr/lf

Comment 3

17 years ago
This is probably everywhere.  Using Mozilla Win2k build 2001102203, simply
select a small portion of text from a comment in this bug, paste it into
Notepad, watch two carriage returns get added to the pasted content.

Comment 4

17 years ago
Related: bug 98572, bug 75283
Sterling Bates, you're just seeing bug 98572.  David, do bug 98572 or bug 75283 
describe what you see?

Comment 6

17 years ago
No response. Reporter initially mentions this frequently happens when selecting
frmo a signature. Signatures are commonly pre-formatted text.
Resolving as dup of bug 98572

*** This bug has been marked as a duplicate of 98572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.