Closed Bug 1064490 Opened 7 years ago Closed 7 years ago

[Cost Control] Data Usage widget in the Notification Tray does not indicate when the data alert limit has been exceeded.

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: Marty, Unassigned)

Details

(Keywords: regression, smoketest)

Attachments

(3 files)

Description:
If the user exceeds their set data limit, the notification tray widget only displays what the limit value was set to, but does not indicate how much data has actually been used, or if the user has exceeded that value.

Note: If the user has not yet hit the data limit, the widget displays how much data is still available ('XX KB available'), but nothing is displayed after exceeding the limit.


Repro Steps:
1) Update a Flame to 20140908040204
2) Set up a data alert in the Usage app for 10 MB
3) Navigate the internet (such as youtube) and exceed the data limit.
4) Pull down the Notification tray to observe the data usage widget.


Actual:
The user is not informed they have surpassed their limit.


Expected:
The user is informed that they have surpassed their limit.

Environmental Variables:
Device: Flame Master
Build ID: 20140908040204
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: 892768985915
Version: 35.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/8938/
See attached: screenshot, logcat
Attached image 2014-09-08-12-46-09.png
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional regression that fails smoketest of this app.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
This issue does NOT occur in Flame 2.1.
Flame 2.1 UI displays a usage bar that indicates when data usage has been exceeded.

Environmental Variables:
Device: Flame 2.1
Build ID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (2.1)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
This issue was caused by bug 1038723.

B2g-inbound Regression Window

Last working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140902113703
Gaia: 7e469783859785a8bd4bf02a802f32561c84be7b
Gecko: 1d3b0ec6e32d
Version: 35.0a1 (2.2) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140902122901
Gaia: 271c527d57c845e0c38b42deed91e8a89a137f1a
Gecko: a73392bff404
Version: 35.0a1 (2.2) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last working gaia / First broken gecko - Issue does NOT occur
Gaia: 7e469783859785a8bd4bf02a802f32561c84be7b
Gecko: a73392bff404

First broken gaia / Last working gecko - Issue DOES occur
Gaia: 271c527d57c845e0c38b42deed91e8a89a137f1a
Gecko: a73392bff404

Gaia Pushlog:  https://github.com/mozilla-b2g/gaia/compare/7e469783859785a8bd4bf02a802f32561c84be7b...271c527d57c845e0c38b42deed91e8a89a137f1a
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
broken by bug 1038723 ?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gmarty)
Attached image Screenshot
I can't replicate the bug. This is what I get (see attachment).
Can you retry with the latest master?
Flags: needinfo?(gmarty)
QA Wanted to double check STR
Keywords: qaurgent, qawanted
QA Contact: jmercado → pcheng
On the reported build ID 20140908040204 I observed: When data limit is passed, the utility tray shows an incorrect number of available data usage in red. It should show that it has passed the limit in red.

On the latest tinderbox build ID 20140908163110 I observed: When data limit is passed, a notification alert actually shows up with sound, and when utility tray is pulled down, it shows how much data usage it has passed over limit in red - which is the expected behavior.

I also checked latest nightly user build to make sure it behaves the same way as latest tinderbox, and it does. Since lately we've been seeing some differences in nightly user builds vs. tinderbox eng builds.

I suspect this bug has been addressed by the fix for bug 1058550 which was landed yesterday.

Tested on:
(bug repro's, nightly user build)
Device: Flame
Build ID: 20140908040204
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: 892768985915
Version: 35.0a1
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

(no repro, tinderbox eng build)
Device: Flame
BuildID: 20140908163110
Gaia: 4acd3e69b263b54f4111e3586ff4ade84b49b4da
Gecko: 6b8da5940f74
Version: 35.0a1
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

(no repro, nightly user build)
Device: Flame
BuildID: 20140909040219
Gaia: 4acd3e69b263b54f4111e3586ff4ade84b49b4da
Gecko: 6b8da5940f74
Version: 35.0a1
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, qawanted
Confirming that this issue does not occur in today's Flame 2.2 build.
Resolving works-for-me.  We are no longer seeing the issue reported.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(jmitchell)
Resolution: --- → WORKSFORME
blocking-b2g: 2.2? → ---
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
You need to log in before you can comment on or make changes to this bug.