Closed Bug 1064625 Opened 8 years ago Closed 7 years ago

Intermittent resource-metadata-management/document-lastModified-01.html | Date returned by lastModified is in the user's local time zone | Date returned by lastModified is in the form "MM/DD/YYYY hh:mm:ss"

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1102907

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Test Start:  16:38:59
Test Finish: 16:39:01

James, can we please make this test a bit smarter about what happens if the minute on the clock happens to change while it's running? :) :P

https://tbpl.mozilla.org/php/getParsedLog.php?id=47636420&tree=Mozilla-Inbound

Ubuntu VM 12.04 x64 mozilla-inbound opt test web-platform-tests-2 on 2014-09-08 16:24:40 PDT for push 879dcad4aded
slave: tst-linux64-spot-001

16:38:59     INFO - TEST-START | /html/dom/documents/resource-metadata-management/document-lastModified-01.html
16:39:01  WARNING - TEST-UNEXPECTED-FAIL | /html/dom/documents/resource-metadata-management/document-lastModified-01.html | Date returned by lastModified is in the user's local time zone. - assert_equals: Hours and minutes should match local time. expected "16:39" but got "16:38"
16:39:01  WARNING - TEST-UNEXPECTED-FAIL | /html/dom/documents/resource-metadata-management/document-lastModified-01.html | Date returned by lastModified is in the form "MM/DD/YYYY hh:mm:ss". - assert_equals: mm part should match minutes. expected "39" but got "38"
16:39:01     INFO - TEST-FAIL | /html/dom/documents/resource-metadata-management/document-lastModified-01.html | Date returned by lastModified is current. - assert_equals: expected "Mon Sep 08 2014 16:39:00 GMT-0700 (PDT)" but got "Mon Sep 08 2014 16:38:59 GMT-0700 (PDT)"
16:39:01     INFO - TEST-OK | /html/dom/documents/resource-metadata-management/document-lastModified-01.html | took 1374ms
Comment on attachment 8547700 [details] [diff] [review]
Update web-platform-test document-lastModified-01.html to revision 807051594288d448e2406ceab40e77549d7753b9

Review of attachment 8547700 [details] [diff] [review]:
-----------------------------------------------------------------

This patch is right and but will land as part of the next wpt upgrade which is running through try as we speak.
Attachment #8547700 - Flags: review?(james)
Awesome - check the try run above - there seems to still be an issue with:

assert_approx_equals: (initial value was 1421090169) expected 1421090174 +/- 2.5 but got 1421090169
Right, updating the test hasn't fixed the fact that gecko has a bug per spec (it computes document.lastModified once on page load rather than just always returning the current time). Filed 1120649 on that.
This was fixed by bug 1102907
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1102907
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.