Closed Bug 1064643 Opened 5 years ago Closed 5 years ago

[RTL] Email account set-up RTL input behaves strangely.

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86
macOS
defect
Not set

Tracking

(ux-b2g:2.2, b2g-v2.2 verified)

VERIFIED FIXED
ux-b2g 2.2
Tracking Status
b2g-v2.2 --- verified

People

(Reporter: swilkes, Unassigned)

References

Details

Attachments

(1 file)

Set language to Arabic.
Restart phone. Click on email to set up new account.
Observe that input fields are RTL.
Enter your email address, and use one with a "." in it, like stephany.bugs@gmozilla.com. 

Observe the the period moves all the way to the left and the text displays in red, but upon typing the next character the period returns to the right, to the position it should have. Same with the @ symbol. The RTL input is working properly (the finished email address looks correct and the password works) but the UI glitches of flashing and showing red should not occur. Minor UI fix.
This is fixed as by the commit in bug 1064617 comment 11.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Keywords: verifyme
Attached video Verify video
Hi Stephany,
I think the problem of "period moves all the way to the left and the text displays in red" have been verified pass. But the finished email address was LTR. Could you help me to confirm whether this bug is verified pass or fail? Thanks!
See attachment: Verify_video.MP4

Flame 2.2 build:
Gaia-Rev        0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c6aa604a7967
Build-ID        20150126002536
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150126.042138
FW-Date         Mon Jan 26 04:21:49 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(swilkes)
You bet, and thanks for the video (very helpful). Since the keyboard and typing are in English, it's OK and expected that the finished email address would be LTR (as we would expect to see for an LTR language). Thanks! Agree this is RESOLVED FIXED.
Flags: needinfo?(swilkes)
Per comment#2 and comment#3, clear the verifyme keywords.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Flags: in-moztrap-
Test case has been added in moztrap:https://moztrap.mozilla.org/manage/case/15274/
Flags: in-moztrap- → in-moztrap+
You need to log in before you can comment on or make changes to this bug.