Closed Bug 1064765 Opened 5 years ago Closed 5 years ago

[Flame][KitKat] Speaker not working on custom builds

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 fixed)

VERIFIED FIXED
2.1 S4 (12sep)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- fixed

People

(Reporter: jaoo, Assigned: viralwang)

References

Details

Attachments

(1 file)

STR:

- |BRANCH=v2.0 ./config.sh flame-kk && ./build.sh && ./flash.sh| (using base image v180 for backup-flame folder)

ACTUAL RESULT:

Speaker doesn't work.

EXPECTED RESULT:

Speaker working correctly
See Also: → 1055305
Hey guys, is this issue known? I did a fresh build by following the steps above and after flashing the build the speaker stopped working (it was working on the base image).
Flags: needinfo?(vwang)
Flags: needinfo?(tchung)
Flags: needinfo?(mwu)
Blocks: 1036490
Flags: needinfo?(mwu)
setting ni to Michael again, I cleared it by mistake, sorry
Flags: needinfo?(mwu)
flash gecko/gaia can not reproduce this bug and it only happened when we do fully flashing. (both v165/v180)
I think bug 1055569 already add necessary files for audio and work that time.
need some time to find out why audio not working now.
Flags: needinfo?(vwang)
note: audio can work with earphone, but not work in speaker
[Blocking Requested - why for this release]:

Yes!  i hit this issue on yesterday's 2.1 KK tinderbox build also!   Unable to use the speakerphone to hear phone calls or even audio applications.  We don't see this on 2.1 JB, so its likely isolated to full flash, 2.1, KK image as Viral mentioned.   I was on v166 when this happened.

Viral, is this a vendor issue?  If so, please change the component to Vendcom, and seek an assignee for this.  I worry that Firefox OS::General will get lost.   I'm going to flag this for blocking-b2g=2.1, since KK is the shipping environment.
blocking-b2g: --- → 2.1?
Flags: needinfo?(tchung)
QA Wanted - Does this reproduce on the KK base image?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #6)
> QA Wanted - Does this reproduce on the KK base image?

Fwiw we did not reproduce it on our side, i.e. before doing the full flash it worked as expected.
:mwu, do you think this is a flashing bug or a real issue with the KK image?
(In reply to Jason Smith [:jsmith] from comment #6)
> QA Wanted - Does this reproduce on the KK base image?

this is a KK image, v166, full flashing tinderbox mozilla-aurora 2.1 builds
Hi Michael,

Since t2m use their own speaker config, seems like we should not copy file from CAF. Could you please help to review it?
Thank you.
Attachment #8486957 - Flags: review?(mwu)
Comment on attachment 8486957 [details] [review]
Bug 1064765 - use t2m mixer_paths.xml to enable speaker

Thanks. Any idea if this might fix bug 1043813 too?
Attachment #8486957 - Flags: review?(mwu) → review+
Flags: needinfo?(mwu)
Hi Michael,

I think the mixer_path.xml only impact the speaker.
In bug 1043813, it looks like receiver volume is too low.
this patch should not fix bug 1043813.

The only difference between t2m and CAF is here:
    <path name="speaker">
        <ctl name="RX3 MIX1 INP1" value="RX1" />
        <ctl name="RDAC4 MUX" value="RX3" />
    </path>
Assignee: nobody → vwang
Keywords: qawantedcheckin-needed
(In reply to viral [:viralwang] from comment #10)
> Created attachment 8486957 [details] [review]
> Bug 1064765 - use t2m mixer_paths.xml to enable speaker

It works with this patch, thanks guys!
Master: https://github.com/mozilla-b2g/device-flame/commit/8f988f3950da8d55676b3b77b09d5722b967e07b
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S4 (12sep)
[Blocking Requested - why for this release]:

Bumping to 2.0? since this affects any KK build (2.0 or later)
blocking-b2g: 2.1? → 2.0?
blocking-b2g: 2.0? → 2.0+
Please request Gaia v2.0 and v2.1 approval on this when you get a chance.
Flags: needinfo?(vwang)
Hi Ryan,

I think we already fix this bug in KK+v2.0 and KK+v2.1 already.
This bug only happen when we do fully flashing, changing gecko/gaia won't met the bug.
So it's not a gecko/gaia bug.
All the flame-kk builds share same branch (kitkat) for this change, we don't need to worry about the gecko/gaia version in this case.
Also, JB use different configurations, we should not met this bug.
Thank you!
Flags: needinfo?(vwang)
Verified in v180 base image with following build:
Gaia      d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/1d44dfce2e5b
BuildID   20140910165554
Version   34.0a2
ro.build.date   Wed Sep 10 20:15:02 EDT 2014
ro.bootloader   L1TC10011800
ro.build.version.incremental   eng.cltbld.20140910.201451

Speakerphone was working normally.
Status: RESOLVED → VERIFIED
Maybe this isn't the best place for this comment... but here goes. I recently got a new flame, and did a `./config.sh flame` (not flame-kk, because I'm not sure what that is). After building and flashing, I _think_ I had sound out of my speakers for a while... but I'm not sure. Either way I have no sound now, except out of headphones. Let me know if I can help verify anything.
You need to log in before you can comment on or make changes to this bug.