Remove unnecessary CNG checks in some places

RESOLVED FIXED in mozilla35

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jandem, Assigned: jandem)

Tracking

unspecified
mozilla35
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Assignee

Description

5 years ago
After enabling Ion/TI everywhere (bug 939562) and Ion-compiling non-CNG functions (bug 1045529), there are still some performance problems in non-CNG (chrome) code caused by (unnecessary) CNG checks in various places. I'll post some patches to remove them, so that we can hopefully close the gap between content and chrome even more.
Assignee

Updated

5 years ago
Blocks: 916464
Assignee

Comment 1

5 years ago
This makes the addon in bug 911570 a lot faster.
Attachment #8486320 - Flags: review?(bhackett1024)
Attachment #8486320 - Flags: review?(bhackett1024) → review+
Attachment #8487820 - Flags: review?(bhackett1024) → review+
https://hg.mozilla.org/mozilla-central/rev/d4b3b9593d01
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
You need to log in before you can comment on or make changes to this bug.