[Contacts] Deleting a contact does not remove them from the list

RESOLVED DUPLICATE of bug 1063218

Status

RESOLVED DUPLICATE of bug 1063218
4 years ago
4 years ago

People

(Reporter: rpribble, Assigned: jmcf)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-flame-test-run-2], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8486540 [details]
Logcat.txt

Description:
If a contact is deleted, they will not be removed from the contact list until the contacts app is closed and restarted.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140908000204
2) Navigate to Contacts 
3) Create two new contacts
4) Try to delete on of the contacts
  
Actual:
After tapping delete, the contact will still appear in the contacts list.

Expected: 
The contact disappears from the contact list immediately after being deleted.
  
Environmental Variables:
Device: Flame 2.1 (319MB)
BuildID: 20140908000204
Gaia: a8e4d26555e5713ec6c72270cfd0cfabc096a0d3
Gecko: 746f24f9d21d
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
  
Notes:
  
Repro frequency: 100%
Link to failed test case:
See attached: Video, logcat
(Reporter)

Comment 1

4 years ago
This issue also occurs on the Flame v2.2 and Open_C v2.2.

Device: Flame 2.2 Master (319MB)
BuildID: 20140909040219
Gaia: 4acd3e69b263b54f4111e3586ff4ade84b49b4da
Gecko: 6b8da5940f74
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Open_C 2.2 Master
BuildID: 20140908040204
Gaia: c71fd5d8c9c7cb021c97e5e9fbb29f92b50a084d
Gecko: 892768985915
Version: 35.0a1 (2.2 Master)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

After tapping delete, the contact will still appear in the contacts list.
---------------------------------------------------

This issue does not occur on the Flame v2.0.

Device: Flame 2.0 (319MB)
BuildID: 20140909000202
Gaia: 59a670d40ad7f5966ec7fafcab0f05009bea97ab
Gecko: de70f9a40834
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The contact disappears from the contact list immediately after being deleted.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(ktucker)
(Reporter)

Updated

4 years ago
Flags: needinfo?(ktucker) → needinfo?(dharris)
(Assignee)

Comment 2

4 years ago
[Blocking Requested - why for this release]: a serious bug with serious impact on user experience and perceived quality of the product
blocking-b2g: --- → 2.1?
(Assignee)

Updated

4 years ago
Assignee: nobody → jmcf
(Assignee)

Comment 3

4 years ago
just confirmed this is just a dup of the referenced bug
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1063218

Updated

4 years ago
blocking-b2g: 2.1? → ---
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.