Update SpiderMonkey to a newer autoconf

RESOLVED DUPLICATE of bug 104642

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 104642
4 years ago
3 months ago

People

(Reporter: evilpie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
We are stuck on autoconf2.13 which is obsolete. Would it be possible to update to something more recent?
Or if this is too hard, can we just remove it entirely?
Moving to build config, as that's where any change would have to happen.
Component: JavaScript Engine → Build Config
OS: Linux → All
Hardware: x86_64 → All
We've never updated the top-level configure because newer versions of autoconf made something with subconfigures harder. I'm not sure if that's as big of an issue with the JS configure script, so it's possible we could update it.

I would love to get rid of autoconf entirely, but we haven't figured out how to do that yet.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 104642
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #3)
> We've never updated the top-level configure because newer versions of
> autoconf made something with subconfigures harder. I'm not sure if that's as
> big of an issue with the JS configure script, so it's possible we could
> update it.

We do a massive pile of custom autoconf macros that are shared by both top-level configure and js/src configure. It would probably be as much effort to only partially port to a newer configure as it would be to just write our own replacements (which we're pretty much already well down the road on).
The only thing that should be done with js/src/configure.in is to merge it with top-level configure.in, or convert it to something else than autoconf (the latter is planned).
Tom Tromey just joined Mozilla. I'm sure he'd *love* to talk about this stuff ;)

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.