Closed Bug 1065436 Opened 5 years ago Closed 5 years ago

Ensure e10s is disabled for Mozmill until bug 695026 is fixed

Categories

(Testing Graveyard :: Mozmill, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

(Whiteboard: [mozmill-2.0.7+])

Attachments

(1 file)

I have been told that e10s will be enabled by default for Nightly builds soon. Given that Mozmill is not able to handle those builds, we have to set the pref 'browser.tabs.remote' to false.

This bug is blocking Mozmill 2.0.7.
The actual pref we have to modify here is 'browser.tabs.remote.autostart = false'.
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
So far we have always added the necessary preferences to the mozprofile class directly. But given that we cannot disable it at this level, we have to find a way to get this sanely added to Mozmill itself. See also bug 905400.
Please keep in mind that we also have to set 'browser.displayedE10SPrompt' to 5, to not getting the prompt for the e10s opt-in. See the landed patch on bug 1064885.
Btw. a tinderbox build with this prompt should appear shortly here:
https://tbpl.mozilla.org/?tree=Fx-Team&rev=15204230df1d

I will use it for testing our changes.
Attached patch Disable e10s v1Splinter Review
I hate to add preferences to Mozmill given that it has to be done on various places. We should really consolidate that to a single place to reduce risks of regressions.
Attachment #8487894 - Flags: review?(ahalberstadt)
Comment on attachment 8487894 [details] [diff] [review]
Disable e10s v1

Review of attachment 8487894 [details] [diff] [review]:
-----------------------------------------------------------------

Lgtm!
Attachment #8487894 - Flags: review?(ahalberstadt) → review+
https://github.com/mozilla/mozmill/commit/42fc84ca44a8420fff2bc7cae67095076632c30a (master)
https://github.com/mozilla/mozmill/commit/3b46e1066c4016b090160a725ab5ddc0f8650c4d (hotfix-2.0)

Gavin, I assume that with the next nightly build this notification will be visible, given that your patch landed on m-c?

If that is the case lets hope that we can get mozmill 2.0.7 out today. Lots of work still to do, with that short heads-up. :( Otherwise we might expect a lot of failures due to this extra notification stealing the focus.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Comment on attachment 8487894 [details] [diff] [review]
Disable e10s v1

Review of attachment 8487894 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozmill/mozmill/__init__.py
@@ +128,5 @@
>              preferences['focusmanager.testmode'] = True
>          elif isinstance(preferences, list):
> +            # Bug 695026 - Re-enable e10s when fully supported
> +            preferences.append(('browser.tabs.remote', False))
> +            preferences.append(('browser.tabs.autostart', False))

This should be 'browser.tabs.remote.autostart'. Also 'browser.tabs.remote' was depreciated about a week ago.
(In reply to Jim Mathies [:jimm] from comment #8)
> > +            # Bug 695026 - Re-enable e10s when fully supported
> > +            preferences.append(('browser.tabs.remote', False))
> > +            preferences.append(('browser.tabs.autostart', False))
> 
> This should be 'browser.tabs.remote.autostart'. Also 'browser.tabs.remote'
> was depreciated about a week ago.

Hm, strange. I wonder why this was originally working for me with that autostart pref. I will get this fixed via bug 1081996. Will the removal of 'browser.tabs.remote' cause a conflict with one of the latest nightlies since the e10s prompt has been landed?
Flags: needinfo?(jmathies)
(In reply to Henrik Skupin (:whimboo) from comment #9)
> (In reply to Jim Mathies [:jimm] from comment #8)
> > > +            # Bug 695026 - Re-enable e10s when fully supported
> > > +            preferences.append(('browser.tabs.remote', False))
> > > +            preferences.append(('browser.tabs.autostart', False))
> > 
> > This should be 'browser.tabs.remote.autostart'. Also 'browser.tabs.remote'
> > was depreciated about a week ago.
> 
> Hm, strange. I wonder why this was originally working for me with that
> autostart pref. I will get this fixed via bug 1081996. Will the removal of
> 'browser.tabs.remote' cause a conflict with one of the latest nightlies
> since the e10s prompt has been landed?

I don't think so, the prompts are controlled by other prefs. The browser.tabs.remote bug is bug 1072417.
Flags: needinfo?(jmathies)
Ok, will both parts be updated. Thanks Jim!
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.