Closed Bug 1065590 Opened 5 years ago Closed 3 years ago

Full-screen on videos bugged when dragging out tabs

Categories

(Core :: Plug-ins, defect)

31 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: lupus.rutilus, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20140716183446

Steps to reproduce:

1. You need 2 screens.
2. Open the browser and add a couple of tabs.
3. Watch a video on one of the tabs (e.g. Youtube or Twitch).
4. Drag the video-tab out of the window (A) to create a second window (B).
5. Have window A and B on different screens.


Actual results:

If you now start watching in fullscreen, the fullscreen will appear on the wrong screen. It always appears on the screen where window A is located. So even though you made a new window B, it doesn't matter where B is.

If you move window A to the other screen, the fullscreen will also appear on the other screen. Consequently, window B is acting like it is still a tab of window A.

Maybe this is a general problem, that all dragged out tabs don't have their own identity.


Expected results:

The fullscreen should appear on the screen where window B is located, because the video is in window B.
Unable to reproduce.
Please check if the issue occurs using Firefox in safe mode (with your addons disabled):
http://support.mozilla.com/kb/Safe+Mode

And on a new, empty profile:
http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-manager
Flags: needinfo?(lupus.rutilus)
Yes, the same issue still occurs during safe mode and when creating a new empty profile.

However, only with twitch.tv and some other video services. Not Youtube (falsely stated in the bugreport).
Flags: needinfo?(lupus.rutilus)
Confirmed on http://www.twitch.tv/ using 35.0a1 (2014-09-11) Win 7 x64
Status: UNCONFIRMED → NEW
Component: Untriaged → Video/Audio
Ever confirmed: true
Product: Firefox → Core
Component: Audio/Video → Audio/Video: Playback
I'm going to call this a Flash issue.
Component: Audio/Video: Playback → Plug-ins
Resolving old bugs which are likely not relevant any more, since NPAPI plugins are deprecated.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.