Closed Bug 1065733 Opened 10 years ago Closed 7 years ago

When creating a new contact from a text message, contact list flashes first

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.4 --- affected
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: dietrich, Unassigned)

References

Details

Flame, nightly OTA channel (master + mozilla-central), Sept 10.

STR:

1. receive text message from number not in your contacts
2. click the number
3. choose "Create new contact"

Expected: see contact editing screen

Actual: first see contact list, a 1-2 second pause, then contact editing screen
QA Wanted for branch checks.
Keywords: qawanted
This bug repro's on Flame KK builds Flame 2.2, Flame 2.1, Flame 2.0, Flame 1.4 (Base), OpenC 2.2

Actual Results: Contact list screen shown before reaching the edit contact details when trying to add a contact from a non recognized number.

Repro Rate: 7/7

Environmental Variables:
Device: Flame Master
BuildID: 20140911063332
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Version: 35.0a1 (Master) 
Firmware Version: V165
------------------------------------------------
Device: Flame 2.1
BuildID: 20140910165554
Gaia: d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko: 1d44dfce2e5b
Version: 34.0a2 (2.1)
Firmware: v165
------------------------------------------------
Environmental Variables:
Device: Flame 2.0
BuildID: 20140910161756
Gaia: ddec117b2d6ac8ea50d7fd833a9cf0605d5b358b
Gecko: 271294ee1e5a
Version: 32.0 (2.0) 
Firmware Version: v165
------------------------------------------------
Device: Flame 1.4
BuildID: 20140814202332
Gaia: 129211661489feb60bbd6772a44081d23b374f17
Gecko: 
Version: 30.0 (1.4)
Firmware: v165
------------------------------------------------
Environmental Variables:
Device: Open_C Master
BuildID: 20140911063332
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Version: 35.0a1 (Master) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA-Wanted for a video - I'd like to see this before trying to triage / nom-decision
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionqawanted
Unfortunately that's been forever since we are still attached to the single document model, which make us go through the first page of the app and then navigate to the contacts form.

We are working on the haidification of the contacts app, to have separate documents for the different parts of the app and being able to launch, redirect, navigate to specific part of the app.
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #4)
> We are working on the haidification of the contacts app, to have separate
> documents for the different parts of the app and being able to launch,
> redirect, navigate to specific part of the app.

Thanks Francisco. What's the bug # for that work, so we can mark this bug as depending on it?
Flags: needinfo?(francisco)
Video Link:
http://youtu.be/1ZAfFuEE-h0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
triage: based on comment 4 and 5 (and the video) I don't think we need to block on this issue - it is already an issue being worked on and we can revisit it once the dependency has been resolved if necessary.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Dietrich you can follow the work here:

bug 1022646

We managed to have a prototype, now we need to rebase and find the time to fix possible problems. Fingers crossed we would like to have this in 2.2 release timeframe.
Flags: needinfo?(francisco)
Depends on: 1022646
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.