Closed Bug 1065778 Opened 10 years ago Closed 10 years ago

[e10s] The 'ProfileSwitcher 1.6.2' is not e10s compatible

Categories

(Firefox :: Extension Compatibility, defect)

35 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
e10s + ---

People

(Reporter: kthiessen, Unassigned)

References

Details

(Keywords: addon-compat)

Version: Nightly 35.0a1 (2014-09-10)

STR:

1. Enable e10s.
2. Install ProfileSwitcher 1.6.2 in nightly from the Add-Ons page. 
3. Select 'Launch another profile' from the File menu, and pick a profile.
4. When prompted 'Close current profile when switching?' choose 'No.'

Expected:
1. Another browser window appears using the new profile.

Actual:
1. No window appears.
The developer has been contacted through AMO.
I'm the developer of the extension.

I've tested the extension with Firefox 36.0a1, with e10s enabled, and for me it works properly both on Linux and Windows. I couldn't test it with 35.0a1 because on Linux, for some reasons I don't know, I couldn't make work e10s.

Unfortunately I'm not able to test on MAC OSX, so I don't know if there is a specific problem with this OS, sorry.

Could you please try again with 36.0a1?

If it still doesn't work, could you check the broswer console to see if there is some error related to it?

With the nightly and e10s, are you able to launch from the command line a second profile of Firefox using the flag "-no-remote" or "-new-instance"?

Thanks for your collaboration.
Karl: can you please verify whether ProfileSwitcher works with e10s now?
Flags: needinfo?(kthiessen)
Sorry for the delay -- holidays and such.

Yes, ProfileSwitcher now works with e10s.  Thanks.
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: needinfo?(kthiessen)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.