RESOLVED DUPLICATE of bug 106527

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 106527
16 years ago
9 years ago

People

(Reporter: selmer (gone), Assigned: David Hyatt)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Incident ID 37144160
Stack Signature HTMLAttributesImpl::SetAttributeName d5590b54
Bug ID
Trigger Time 2001-10-24 16:55:05
Email Address selmer@netscape.com
URL visited
User Comments Had 2 tabs open: welcome page & N.com. Had 3rd tab loading from a
cgi and tried to use the context menu to open a link into a 4th tab when I crashed.
Build ID 2001102415
Product ID MozillaTrunk
Platform ID Win32
Trigger Reason Access violation
Stack Trace
HTMLAttributesImpl::SetAttributeName
[d:\builds\seamonkey\mozilla\content\html\style\src\nsHTMLAttributes.cpp, line 1056]
HTMLAttributesImpl::SetAttributeFor
[d:\builds\seamonkey\mozilla\content\html\style\src\nsHTMLAttributes.cpp, line 1233]
HTMLStyleSheetImpl::SetAttributeFor
[d:\builds\seamonkey\mozilla\content\html\style\src\nsHTMLStyleSheet.cpp, line 1204]
nsGenericHTMLElement::SetHTMLAttribute
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp,
line 2078]
nsGenericHTMLElement::SetAttr
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp,
line 1867]
HTMLContentSink::AddAttributes
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 809]
HTMLContentSink::ProcessMETATag
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 4605]
HTMLContentSink::AddLeaf
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3474]
CNavDTD::AddLeaf [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 3774]
CNavDTD::AddHeadLeaf [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3833]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1719]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 895]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 526]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1969]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1833]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2490]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 260]
nsStreamListenerTee::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerTee.cpp, line 57]
nsHttpChannel::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 2361]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerProxy.cpp, line 203]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
0x00170010
(Reporter)

Comment 1

16 years ago
Adding Crash keyword
Keywords: crash
(Reporter)

Comment 2

16 years ago
Also got this same crash trying to use talkback quicksearch to find the stack
trace shown above.  Here's the info from that report:

Incident ID 37144209
Stack Signature HTMLAttributesImpl::SetAttributeName 3b085206
Bug ID
Trigger Time 2001-10-24 16:57:01
Email Address selmer@netscape.com
URL visited
User Comments Crash searching talkback by email address. Ironic isn't it? :-)
Build ID 2001102415
Product ID MozillaTrunk
Platform ID Win32
Trigger Reason Access violation
Stack Trace
HTMLAttributesImpl::SetAttributeName
[d:\builds\seamonkey\mozilla\content\html\style\src\nsHTMLAttributes.cpp, line 1056]
HTMLAttributesImpl::SetAttributeFor
[d:\builds\seamonkey\mozilla\content\html\style\src\nsHTMLAttributes.cpp, line 1169]
HTMLStyleSheetImpl::SetAttributeFor
[d:\builds\seamonkey\mozilla\content\html\style\src\nsHTMLStyleSheet.cpp, line 1185]
nsGenericHTMLElement::SetAttr
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp,
line 1903]
HTMLContentSink::AddAttributes
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 809]
SinkContext::OpenContainer
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 1494]
HTMLContentSink::OpenContainer
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3428]
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3455]
CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1304]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1713]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 895]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 526]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1969]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1833]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2490]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 260]
nsStreamListenerTee::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerTee.cpp, line 57]
nsHttpChannel::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpChannel.cpp, line 2361]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerProxy.cpp, line 203]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
(Reporter)

Comment 3

16 years ago
Sorry for putting this in tabs area, it crashes just clicking through to the URL
http://info.netscape.com/fwd/hop10te1.1/http://computing.netscape.com/computing/main.tmpl

Please forward as appropriate.
Summary: Crash opening 4th tab via context menu → Crash going to URL http://info.netscape.com/fwd/hop10te1.1/http://computing.netscape.com/computing/main.tmpl

Comment 4

16 years ago
loads just fine on linux with the fix for bug 106527. (also see bug 106465)
Same stack - marking dup

*** This bug has been marked as a duplicate of 106527 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.