Closed Bug 1066247 Opened 6 years ago Closed 5 years ago

Thunderbird 31 Lightning 3.3 Not Responding when connecting to a calendar

Categories

(Calendar :: General, defect)

Lightning 3.3
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 875739

People

(Reporter: karl.rossing, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.94 Safari/537.36

Steps to reproduce:

Thunderbird 31 + Lightning 3.3
Connecting to an users caldav calendar causes TB lock up and freeze with not responding. The problem occurs on windows and mac.


Actual results:

This happens to a number of our users. However the problem does not happen to my calendar or other support tech's calendars. If I share the problematic users calendar to myself and configure lightning to use the problematic users calendar, it will freeze my thunderbird too.


Expected results:

I believe that it's an issue with a specific event or invitation. I tried to enable calendar logging but it does not seem to log to a file.

It seems that the freeze happens right after the initial calendar read.

CALDAV server is Oracle Calendar Server 7.0.4.15.0 (which is the latest).
Attached image lightning-frozen.png
We managed to track it down to the X-RECEIVED entries below.


BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Oracle Corporation/CS 7.0.4.15.0//EN
BEGIN:VEVENT
UID:fe7db9df-9943-485e-961f-2ce9d7960412
DTSTAMP:20140825T201943Z
SUMMARY:This is a Summary
DTSTART;TZID=America/Chicago:20140828T100000
DTEND;TZID=America/Chicago:20140828T110000
CREATED:20140825T201159Z
LAST-MODIFIED:20140826T175733Z
ORGANIZER;PARTSTAT=ACCEPTED;ROLE=CHAIR;RSVP=TRUE;SCHEDULE-STATUS=1.2:mail
to:somewhere@aol.com
STATUS:CANCELLED
LOCATION:board room
DESCRIPTION:This is a description
ATTENDEE;CN=Attendee 1;PARTSTAT=DECLINED;ROLE=REQ-PARTICIPANT;RSVP=TRUE;X-R
ECEIVED-DTSTAMP=20140825T201846Z;X-RECEIVED-DTSTAMP=20140825T201846Z;X-R
ECEIVED-SEQUENCE=0;X-RECEIVED-SEQUENCE=0:mailto:attendee1@aol.com
X-MOZ-GENERATION:1
END:VEVENT
X-NSCP-WCAP-ERRNO:0
END:VCALENDAR
Can you please add the event as attachment to the bug? Syntax-wise it looks not wrong, but I want to be sure there's no line break issue.

Have you icaljs enabled (-> about:config) when experiencing the issue?
Attached file freezing.ics
If you mail the attachment to a thunderbird + lighting user, lightning will try to process the invitation and then crash.
icaljs was disabled.
Attachment #8507153 - Attachment mime type: text/calendar → text/plain
Can you please check whether this is also an issue if icaljs is enabled?
Comment on attachment 8507153 [details]
freezing.ics

This seems related to Bug 875739 although the inducing parameters are different. As you can see the X-RECEIVED-DTSTAMP and the X-RECEIVED-SEQUENCE parameters are duplicated:

> ATTENDEE;CN=Stephen Tim;PARTSTAT=ACCEPTED;ROLE=REQ-PARTICIPANT;RSVP=TR
>  UE;X-RECEIVED-DTSTAMP=20141016T183321Z;X-RECEIVED-DTSTAMP=20141016T18332
>  1Z;X-RECEIVED-SEQUENCE=0;X-RECEIVED-SEQUENCE=0:mailto:stephen.tim@domain.com

When I remove the duplicates as shown below Thunderbird doesn't freeze anymore.

> ATTENDEE;CN=Stephen Tim;PARTSTAT=ACCEPTED;ROLE=REQ-PARTICIPANT;RSVP=TR
>  UE;X-RECEIVED-DTSTAMP=20141016T18332
>  1Z;X-RECEIVED-SEQUENCE=0:mailto:stephen.tim@domain.com
Actually Bug 875739 Comment 3 talks about the same x-params -> duplicate. 

Seems that your sample and the sample in attachment 797887 [details] were produced by Oracle calendar server. Don't know if the duplications are an error in this server.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875739
>Seems that your sample and the sample in attachment 797887 [details] were produced
>by Oracle calendar server. Don't know if the duplications are an error in this server.

I placed a service all with Oracle Calendar and this is what they had to say

"The Calendar Developers confirmed that the server has no real knowledge of these parameters and does not create them"
I don't program a lot.  But let me offer you my help to narrow down the cause of the problem.

First of all, X-Param are non-standard or proprietary values.  Is there any document explaining the use of X-RECEIVED-SEQUENCE and/or X-RECEIVED-DTSTAMP?

Secondly, is there any public "Oracle Calendar Server" to which I could create events and try to reproduce the error?
I think we reasonably can keep the discussion in bug 875739, if Karl can confirm in reply to comment #6 that the issue does not occur, if icaljs is enabled (what I assume).
I can get back into calendar if i:

1) Start Thunderbird in safe mode
/Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin -safe-mode

2) Set calendar.icaljs=true in the config editor

3) Restart Thunderbird.

what does calendar.icaljs do? What are the side effects?
(In reply to Karl Rossing from comment #12)

I think it would be better if you do the test in the following order:
1. Install a new Thunderbird and Lightning, eg in a new computer which has never connected to the problem calendar (or remove user profile to make it clean, if you see what this means)

2. Set calendar.icaljs=true in the config editor

3. Connect to the problem calendar and check if TB would freeze or not

icaljs is an alternative iCal parsing engine to libical, from what I understood ;)
I came across this
https://bugzilla.mozilla.org/show_bug.cgi?id=534228

There seems to be some received-sequence code as per
http://code.metager.de/source/search?q=RECEIVED-SEQUENCE&project=mozilla
Thank you for the hint. From what I have seen in the patch, the fix of that bug may also resolve this one because the params are not longer considered, even though this bug is still more a duplicate of bug 875739.
The issue i'm having is with X-RECEIVED-SEQUENCE and not RECEIVED-SEQUENCE. Does the patch in https://bugzilla.mozilla.org/show_bug.cgi?id=534228 cover that?

We can move this conversation to https://bugzilla.mozilla.org/show_bug.cgi?id=875739 if you wish.
You need to log in before you can comment on or make changes to this bug.