Closed Bug 1066289 Opened 5 years ago Closed 4 years ago

[Vertical Homescreen] Browser icon is moved to the bottom of the home screen after 2.0 to 2.1 OTA

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected

People

(Reporter: ychung, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [2.1-flame-test-run-2][systemsfe][2.1-flame-test-run-3])

Attachments

(3 files)

Description:
After OTA upgrade from 2.0 to 2.1, the Browser icon does NOT stay at the same place as before. The icon moves to the bottom of the screen.

Repro Steps:
1) Flash the Flame device to 2.0 (BuildID: 20140910000203).
2) Upgrade the device OTA to 2.1.
3) Observe the home screen when the upgrade is done.

Actual:
The Browser app move to the bottom of the screen.

Expected:
The Browser app stays at the same place on the home screen. All icons keep the same order after OTA.

[Before OTA - Flame 2.0]
Environmental Variables:
Device: Flame 2.0(319mb)
BuildID: 20140910000203
Gaia: 3f4c635106c5364228782d12b1cb76b0c105b971
Gecko: 02a5b9234c13
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

[After OTA - Flame 2.1]
Environmental Variables:
Device: Flame 2.1(319mb)
BuildID: 20140911000225
Gaia: d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko: 1d44dfce2e5b
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Repro Frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/13229/
See attached: logcat, screenshot
Attached image IconMovedAfterOTA.png
This issue also reproduces on Flame 2.0 to 2.1 with 512mb:

[Before OTA - Flame 2.0]
Environmental Variables:
Device: Flame 2.0(512mb)
BuildID: 20140910000203
Gaia: 3f4c635106c5364228782d12b1cb76b0c105b971
Gecko: 02a5b9234c13
Version: 32.0 (2.0) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

[After OTA - Flame 2.1]
Environmental Variables:
Device: Flame 2.1(512mb)
BuildID: 20140911000225
Gaia: d61264cd0c1f797b6be11e33524d8d52983c87e4
Gecko: 1d44dfce2e5b
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

The Browser app moves to the bottom of the screen after OTA.

===============================================
This issue does NOT reproduce on A) Flame 2.1 to 2.2 OTA, B) Flame 1.4 to 2.0:

A) [Before OTA - Flame 2.1]
Environmental Variables:
Device: Flame 2.1(319mb)
BuildID: 20140910000202  
Gaia: 79dc972d637ff5ef7667b231e93118b4ed83ba9c
Gecko: 0890010015a2
Version: 34.0a2 (2.1)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

[After OTA - Flame 2.2]
Environmental Variables:
Device: Flame 2.2(319mb)
BuildID: 20140911064110
Gaia: e3b9d0d6516177636965d97c63c60981a24a0662
Gecko: 98ea98c8191a
Version: 35.0a1 (2.2)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

B) [Before OTA - Flame 1.4]
Environmental Variables:
Device: Flame 1.4(319mb)
BuildID: 20140910000204
Gaia: 6018a1c18f0c3eab25aac2ba3064904740591dd2
Gecko: 90e68c490bf9
Version: 30.0 (1.4) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

[After OTA - Flame 2.0]
Enviromental Variables:
Device: Flame 2.0
BuildID: 20140911000231
Gaia: ddec117b2d6ac8ea50d7fd833a9cf0605d5b358b
Gecko: 271294ee1e5a
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The icons keep the same order on the homescreen after OTA.
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
This is not ideal but I don't this is serious enough to block on.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attached image Marketplace.png
Marketplace icon also drops to the bottom of the screen when the device is restarted after the OTA. Screenshot is attached.
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Whiteboard: [2.1-flame-test-run-2] → [2.1-flame-test-run-2][systemsfe]
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.1-flame-test-run-2][systemsfe] → [2.1-flame-test-run-2][systemsfe][2.1-flame-test-run-3]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
blocking-b2g: --- → backlog
blocking-b2g: backlog → ---
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.