[devtools] Can't inspect shadow-dom in the inspector

RESOLVED DUPLICATE of bug 777674

Status

RESOLVED DUPLICATE of bug 777674
4 years ago
3 months ago

People

(Reporter: wilsonpage, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Currently we have no way of inspecting shadow-dom in devtools inspector. This is making developement/debugging tricky, especially as Gaia is ramping up web-component usage.
So what we need here are hooks for devtools to use, right?  What are the right hooks?
Blocks: 893669

Updated

4 years ago
Flags: needinfo?(pbrosset)
I haven't had the chance to follow bug 777674 as closely as I wanted to, but for me, that's the bug that was originally open for supporting pseudo-elements, xbl AND shadow dom in the devtools.
In order to narrow the scope and make it easier to ship something, I thing the bug is only being used right now for pseudo-elements, but the platform ground work done there is probably going to be useful to support shadow dom in the near future too.
NI? bgrins as he sure knows more.
Flags: needinfo?(pbrosset) → needinfo?(bgrinstead)
The most basic level of Shadow DOM inspection will be supported by Bug 777674.  After this bug, Shadow DOM content will show up as a child of the host element - shadow roots will not be visible right away. Please see (and comment in) Bug 1053898 if you are interested in how shadow roots will be displayed in the markup view, especially when dealing with multiple shadow roots.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(bgrinstead)
Resolution: --- → DUPLICATE
See Also: → bug 1053898
Duplicate of bug: 777674

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.