Closed Bug 1066731 Opened 5 years ago Closed 5 years ago

Bug 991035 breaks build when --with-ccache=foo is used

Categories

(Firefox Build System :: General, defect)

33 Branch
x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1066669

People

(Reporter: ekr, Unassigned)

Details

Bug 991035 tries to remove --with-ccache=foo from the build lines using the
following sed command:

  sed -e 's/--with-ccache\S* *//'`

Unfortunately, at least on Mac, sed defaults to basic regular expressions
and \S is a "modern" regular expression, so if you have --with-ccache=foo,
the =foo part doesn't match and you end up with the "=foo" sticking around,
which breaks the build.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1066669
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.