Closed Bug 1066842 Opened 8 years ago Closed 8 years ago

[e10s] Firefox hangs or crashes when opening and closing 50 tabs

Categories

(Firefox :: Extension Compatibility, defect)

33 Branch
x86
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
e10s m4+ ---

People

(Reporter: tenisthenewnine, Assigned: ally)

References

Details

(Keywords: hang)

Hi,

https://addons.mozilla.org/en-US/firefox/addon/xnotifier/ 

130k users so might be a problem with it being an option on the newest nightlies...

This addon was working perfectly with 0 crashes before the beginning of August with e10's enabled. I had reported it as a working addon when arewee10syet.com first started, yet somethings recently changed.

Now it works like it should, however I can easily reproduce a crash with this addon under certain conditions. Again, this has only happened since around the 12th of August or so (I can't pinpoint the exact changeset).

1. Install this addon and set it up with a gmail account etc
2. Open a new e10's window and either A. Open a ton of bookmarks or B. run the Membench benchmark.
3. After many tabs have been opened, right click on one of the opened tabs and click "close other tabs".
4. The plugin-container.exe goes to 0% CPU and firefox stops responding. The RAM use drops on the child process, which is interesting as something must still be happening. Firefox's main process CPU, at least on my system, sits at 2% like it normally would. If you don't get a crash, repeat step 2 and 3 until it happens. Sometimes it takes more than a few attempts.
5. Kill the plugin-container and Firefox starts responding and gives an "oops the tab has crashed" error.

I'm not sure why this only started happpening recently or how this addon even is effected by unrelated tabs closing but who knows?

Chris, I had emailed you about this problem. This is the problem addon I was trying to diagnose.

I can reproduce this easily so if you'd like screenshots etc please let me know.

Thanks
Sorry. It's not this addon. The hang happened again about half an hour into the session.

I can't reproduce it in safe mode either.

Does safe mode load a different set of preferences? If it does I'll reset mine and see if I can reproduce afterwards
Grant, so this bug is a browser hang and not related to the X-notifier addon?
Blocks: e10s-addons
tracking-e10s: --- → ?
(In reply to Chris Peterson (:cpeterson) from comment #2)
> Grant, so this bug is a browser hang and not related to the X-notifier addon?

Hi Chris,

Yes Sorry. Should I change the title?


I can now after some time reproduce this crash in safe mode. Open a really heavy session of 50 tabs from a bookmark folder. Wait until it loads a lot of them, and then right click and click "close other tabs".

If it doesn't cause this hang, try again a few more times and then shut the e10's window and the plugin-process will hang.

You mentioned there was the crash reporter for the child process coming up. When is this due?

I'm trying to find the regression range today so I can when it started happening but until I can get the crash reported I'm not sure how else I can help?

It's not the pref.js as I tried a new one, and it's not my addons as I tried it with them disabled.
Grant, do you have a Crash Report ID from about:crashes? I don't think this is a regression. This sounds similar to session restore bug 1037179.
Depends on: 1037179
Keywords: hang
Summary: "X-notifier" add-on does not work with e10s → [e10s] Firefox hangs or crashes when opening and closing 50 tabs
HI Chris,

Nothing comes up in about crashes as it doesn't crash the entire browser, it just hangs the plugin-container process.
Assignee: nobody → ally
I've been unable to reproduce this.

Please re-open if someone finds a solid STR for this
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.