WebGL demo www.babylonjs.com does not work due to <body onload="onload()">

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({site-compat})

Trunk
x86_64
Windows 7
site-compat

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
[Tracking Requested - why for this release]: regression since Firefox31


The problem happens since Firefox31. 
Firefox30, Chrome and IE11 works fine.

Steps To Reproduce:
1. Open http://blogs.msdn.com/b/ie/archive/2014/09/12/making-your-webgl-code-more-flexible.aspx
2. Click a link www.babylonjs.com 
3. Click a thumbnail "WORLDMONGER"
4. Wait for 1 minutes

Actual Results:
Sound playback but no graphic display
And an error shown in Error Console as follows:

Error: too much recursion
Source file: http://www.babylonjs.com/Scenes/Worldmonger/index.html
Line: 1


Expected Results:
Graphic should display


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/64dfd7bc59f9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131104075809
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7e6cb031ed8f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131104081507
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=64dfd7bc59f9&tochange=7e6cb031ed8f

Regressed by:
aea34e69d171	Peter Van der Beken — Bug 932322 - Make Window's WebIDL properties be own properties of window. r=bz.

And Bug 932322 was disabled Firefox28, 29 and 30.

Updated

4 years ago
Keywords: site-compat
The site has:

  <body onload="onload();">

which is definitely something that will go into an infinite loop given event handlers as own props on the global.

This is, imo, just a bug in the page that should be fixed.
Component: DOM → Desktop
Product: Core → Tech Evangelism
Version: 31 Branch → Trunk
Summary: WebGL demo www.babylonjs.com does not work → WebGL demo www.babylonjs.com does not work due to <body onload="onload()">
(Reporter)

Comment 2

4 years ago
The site fixed the problem.
https://github.com/BabylonJS/Samples/issues/1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox32: affected → ---
status-firefox33: affected → ---
status-firefox34: affected → ---
status-firefox35: affected → ---
status-firefox-esr31: affected → ---
tracking-firefox32: ? → ---
tracking-firefox33: ? → ---
tracking-firefox34: ? → ---
tracking-firefox35: ? → ---
tracking-firefox-esr31: ? → ---
Resolution: --- → WORKSFORME
(Reporter)

Updated

4 years ago
Keywords: regression
You need to log in before you can comment on or make changes to this bug.