Closed Bug 1067002 Opened 5 years ago Closed 5 years ago

[e10s] Browser freezes when scrolling a video off-screen on YouTube with HTML5 video enabled

Categories

(Core :: General, defect)

x86
Windows 8.1
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
e10s m3+ ---

People

(Reporter: cwiiis, Assigned: handyman)

References

Details

Frequently, if I watch a video on youtube.com with HTML5 video enabled (youtube.com/html5) and scroll the video off of the page (say, because I'm reading comments or video information), the entire browser will lock up. The video continues to play (though you can't see it). When I kill the browser, the plugin container remains alive and the audio continues to play until either the video finishes or I kill the plugin container.

I see this on videos elsewhere, but YouTube is an easy way to reproduce this. Switching tabs can also trigger this, but I find it happens slightly less frequently.
tracking-e10s: --- → ?
Possible dupe of bug 1049275? I'll keep an eye out after the next nightly.
I still see this on the 2014-09-14 Nightly.
For anyone contending with this, you can avoid a browser crashing by killing Plugin Container instead, but it will also kill every other tab.
Assignee: nobody → davidp99
At some point, this has been fixed - not experienced it for a fair while now.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.