Closed Bug 1067007 Opened 7 years ago Closed 6 years ago

[mozmill] tests do not work after TB build changes

Categories

(Calendar :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Taraman, Assigned: Fallen)

References

Details

Attachments

(1 file, 1 obsolete file)

After the recent build changes the calendar mozmill tests are not running.

The paths still point to "$objdir$/mozilla/<somedir>" ISO "$objdir$/<somedir>"
Thanks for filing the bug, I just noticed this on the tryserver too. Try run with patch applied:

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=12f7cd74972c
The Try Run passed, but the calendar-tests don't seem to be executed.
searching the log for testTodayPane.js which should run show no results.

I tried the same change locally and when running "make -C objdir/calendar/test/mozmill mozmill" I get the error "Binary does not exist: ../../../dist/bin/tunderbird"
The path would be right from objdir/calendar/test/mozmill, but the script seems to run in a different location.
Assignee: nobody → philipp
Does running Thunderbird mozmill tests work for you? I tried make mozmill in objdir, but that complains about a missing mozinfo. Installing that into the virtualenv also gives me the error you are getting: 

Exception: Binary path does not exist ../../../dist/Daily.app/Contents/MacOS/thunderbird-bin
Could try packaging tests and seeing if it runs then.
New try run, I've tested the changes locally and they at least show up in packaged tests' mozmilltests.list now.

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=b1f015505939
Attached patch cal-mozmill-new-build.diff (obsolete) β€” β€” Splinter Review
TB mozmill tests work for me loacally.

I played around a little and this patch fixes this for me on linux.
I don't know from where the relative path should fit, but absolute works.
Attached patch Fix - v2 β€” β€” Splinter Review
This patch contains the changes you've suggested previously, plus some extra changes to make sure the mozmill tests are run when packaged.

Here is a tryserver run that succeeds in so far that the calendar tests are run. The failing imip test is bug 1010294 which is not ready yet, but the other calendar mozmill tests are running.

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=b1f015505939
Attachment #8489226 - Attachment is obsolete: true
Attachment #8489248 - Flags: review?(standard8)
Attachment #8489248 - Flags: review?(standard8) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/f1fe79198f96>
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.7
You need to log in before you can comment on or make changes to this bug.