[e10s] Screenshot button not working in responsive mode

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: trishul.goel, Unassigned)

Tracking

(Blocks 1 bug)

35 Branch
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [e10s-m6])

User Agent: Mozilla/5.0 (X11; Linux i686; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140913030206

Steps to reproduce:

Pressed Ctrl+shift+M and entered responsive mode.
Clicked the screenshot Button.



Actual results:

No screenshot saved


Expected results:

The screenshot must be saved
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Responsive Mode
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Summary: Screenshot button not working in responsive mode → [e10s] Screenshot button not working in responsive mode
See Also: → 1067145
And the touch button.
Even touch button is not working. Only orientation button works.
Error in console: "window is null"
Blocks: 937169
These DevTools bugs should probably block e10s from riding to Aurora.
devtools bugs will block the e10s merge to Aurora, but blassey would like them to be tracked by dte10s meta bug 875871, not the tracking-e10s=m6+ flag.
Whiteboard: [e10s-m6]
Screenshots are working now in e10s. As for the touch button, that's disabled and re-enabling is tracked in Bug 1074180.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.