MSN sites are blocking Mozilla browser

VERIFIED DUPLICATE of bug 104733

Status

--
major
VERIFIED DUPLICATE of bug 104733
17 years ago
4 years ago

People

(Reporter: m-cahill, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
I've been able to log-in to msn.ca for content I can't get on other portals. 
However, as of this morning, Mozilla is being denied with the following message:

<snip>
Attention: Web Browser Upgrade Required to View MSN.ca

If you are seeing this page, we have detected that the browser that you are
using will not render MSN.com correctly. Additionally, you'll see the most
advanced functionality of MSN.com only with Microsoft Internet Explorer 5. If
you wish to visit MSN.com, please select the appropriate free Internet Explorer
download link below.

    * Internet Explorer for Windows
    * Internet Explorer for Macintosh
    * MSN Explorer for Windows

©2001 Microsoft Corporation.  All rights reserved.  Terms of Use  Advertise 
TRUSTe Approved Privacy Statement  GetNetWise

</snip>

My Mozilla version:  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5)
Gecko/20011012

Comment 1

17 years ago
Yes, MSN is now blocking most browsers except for the Microsoft branded browsers :(

Also affected is MSN.com (and probably most of the other re-designed msn sites)

  This is not a blocker.. but should probably be atop the 'most wanted' list of
Evangelism. I'm removing "blocker" status, and demoting it to "major", but
someone may want to lower it even more.  (I dont know how the status of
Evangelism bugs are handled)

I also changed the summary to better reflect the problem.
--> marking as NEW (i searched and found no dupes)

A quote from CNET:
-----------
 "Microsoft is actively keeping our browser from accessing MSN.com," said Jon S.
Tetzchner, Opera's chief executive. He added that every time a browser connects
to a server, it sends a string to the server telling it what type of browser is
seeking access.

"Microsoft is seeing (that) it is an Opera browser and shutting it out," said
Tetzchner, whose team was testing the problem Thursday. "If you change the Opera
string by one letter, it is letting us in."

Earlier versions of the Netscape Navigator browser jammed and crashed when
trying to reach MSN.com. The latest version, 6.1, seems to be working.
-----
(full story at:  http://news.cnet.com/news/0-1005-200-7655334.html?tag=mn_hd )

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: MSN.CA will not allow Mozilla (0.9.5) → MSN sites are blocking Mozilla browser

Updated

17 years ago
Severity: blocker → major

Comment 2

17 years ago
Is there a way to set the string Mozilla is sending msn.com such that msn would
think mozilla was IE?  

Comment 3

17 years ago
Should this depend on bug 97222 or should it be the other way around?

Comment 4

17 years ago
Albert R, I'm not sure which :)  I'll let someone that DOES know change it
themselves :)

  MSN looks for the Mozilla user-agent string, and blocks when it finds a
particular type.

Here is a (temporary) workaround which lets you view the site:

Exit mozilla, and find your  "prefs.js" file.  Add the following to the file,
and save:
---

// Override the default user-agent string:
user_pref("general.useragent.override", "Mozilla/5.0 (X11; U; Linux 2.2.16-22smp
i686; en-US; m18) Gecko/20010110 Netscape6/6.5");

---

This "tricks" MSN.com into letting you view the page.  You can probably modify
that user-agent string to better suit your needs.  I pulled that particular
string from one of the webpages of mozilla.org.

After adding that user-agent overide line, I can visit the msn.com site without
any problems.  Note: The page appears to work fine under Mozilla!  It is almost
identical to the rendering under IE6 (for me at least).

Also, I'm changing Platform/OS to all.
OS: Linux → All
Hardware: PC → All

Comment 5

17 years ago
Should this be marked as dup of bug 104733 ?

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 104733 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
ahh, ok. Now that this bug is duped.. any further comments should be made in 
bug 104733.

marking this one 'verified'
Status: RESOLVED → VERIFIED

Comment 8

16 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: jonrubin → english-other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.