All users were logged out of Bugzilla on October 13th, 2018

Headings in the facebook side bar with RTL UI are misplaced

RESOLVED FIXED in Firefox 34

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: smontagu, Assigned: smontagu)

Tracking

({regression})

Trunk
mozilla35
regression
Points:
---
Bug Flags:
in-testsuite +
qe-verify -

Firefox Tracking Flags

(firefox32 unaffected, firefox33- wontfix, firefox34+ fixed, firefox35 fixed)

Details

Attachments

(4 attachments)

(Assignee)

Description

4 years ago
Created attachment 8489267 [details]
Screenshot of buggy rendering - "news" and "messages" on the same line

I don't see this all the time, and attempts to select the text to view selection source seem to change the behaviour, but I'll work on a minimized testcase. Regression range is http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bdac18bd6c74&tochange=776f6d341b3f, and it's probably caused by http://hg.mozilla.org/mozilla-central/rev/8bc5711c589e from bug 789096
(Assignee)

Comment 1

4 years ago
Created attachment 8489326 [details]
Minimized testcase
(Assignee)

Comment 2

4 years ago
Created attachment 8499201 [details] [diff] [review]
Patch
Attachment #8499201 - Flags: review?(jfkthame)
(Assignee)

Comment 3

4 years ago
Created attachment 8499214 [details] [diff] [review]
Testcase as reftest
Attachment #8499214 - Flags: review?(jfkthame)
(Assignee)

Comment 4

4 years ago
[Tracking Requested - why for this release]:
status-firefox32: --- → unaffected
status-firefox33: --- → affected
status-firefox34: --- → affected
tracking-firefox33: --- → ?
tracking-firefox34: --- → ?
Patch seems reasonable to me for now; eventually we'll want all of this to be logicalized so that it works for floats in vertical layout, but definitely better to be consistent for now than try to compute a width by subtracting a logical and a physical coordinate from each other.
33 beta 9 is going to be released today and you didn't fill a reason for tracking in comment #4. Except if it is a critical issue, 33 will ship with this bug.
tracking-firefox33: ? → -
tracking-firefox34: ? → +
Comment on attachment 8499201 [details] [diff] [review]
Patch

Review of attachment 8499201 [details] [diff] [review]:
-----------------------------------------------------------------

What dbaron said.
Attachment #8499201 - Flags: review?(jfkthame) → review+
Attachment #8499214 - Flags: review?(jfkthame) → review+
https://hg.mozilla.org/mozilla-central/rev/69910e2c2a5d
https://hg.mozilla.org/mozilla-central/rev/9cafd64208c3
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Flags: qe-verify-
status-firefox35: --- → fixed
Simon, do you think this should be uplift to aurora?
Flags: needinfo?(smontagu)
(Assignee)

Comment 11

4 years ago
Comment on attachment 8499201 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: Bug 789096
[User impact if declined]: Overlapping unreadable content in right-to-left languages
[Describe test coverage new/current, TBPL]: reftest in second patch, fix baked on trunk since 2014-10-05
[Risks and why]: mimimal risk
[String/UUID change made/needed]: N/A
Attachment #8499201 - Flags: approval-mozilla-aurora?
Flags: needinfo?(smontagu)
Attachment #8499201 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8499201 [details] [diff] [review]
Patch

Actually, setting it back to aurora="?" and adding beta="?" since it is merge day!
Attachment #8499201 - Flags: approval-mozilla-beta?
Attachment #8499201 - Flags: approval-mozilla-aurora?
Attachment #8499201 - Flags: approval-mozilla-aurora+
status-firefox33: affected → wontfix
Attachment #8499201 - Flags: approval-mozilla-aurora?
Comment on attachment 8499201 [details] [diff] [review]
Patch

Beta+
Attachment #8499201 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.