Closed Bug 1067307 Opened 8 years ago Closed 8 years ago

Crash in firefox OS when tapping on an e.me collection

Categories

(Core :: DOM: Content Processes, defect)

Other
Android
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: zcampbell, Unassigned)

References

Details

(Keywords: qablocker, regression, Whiteboard: [xfail])

Replicable manually: Yes

STR:
1. Long-tap homescreen
2. Add a new collection
3. Tap the collcetion on the homescreen (may need to tap twice)

Nb, this does not work for existing collections. You must add a new one.

Device under test:
Gaia      3cb88f9f55725a3be107127cf6936bc7ffd9452a
Gecko     https://hg.mozilla.org/integration/b2g-inbound/rev/994adb94b4fd
BuildID   20140915015307
Version   35.0a1
Device Name 	 flame
FW-Release 	 4.4.2
FW-Incremental 	 27
FW-Date 	 Thu Sep 4 14:59:02 CST 2014
Bootloader 	 L1TC10011800




First failing build:
https://tbpl.mozilla.org/?tree=B2g-Inbound&rev=bf5fcc0c4b27


Last good build:
https://tbpl.mozilla.org/?tree=B2g-Inbound&rev=c22fbd74e303
The first two lings of this logcat are Marionette tapping the collections icon.

Logcat:

09-14 14:02:38.341 I/Gecko (18720): 1410728558347 Marionette: emitting Touch event of type touchstart to element with id: and tag name: DIV at coordinates (160, 479) relative to the viewport
09-14 14:02:38.351 I/Gecko (18720): 1410728558358 Marionette: emitting Touch event of type touchend to element with id: and tag name: DIV at coordinates (160, 479) relative to the viewport
09-14 14:02:38.361 I/Gecko (18366): IPDL protocol error: could not look up PBlob
09-14 14:02:38.361 I/Gecko (18366): IPDL protocol error: Error deserializing 'remoteBlobParent' (PBlob) member of 'RemoteInputStreamParams'
09-14 14:02:38.361 I/Gecko (18366): IPDL protocol error: Error deserializing 'optionalInputStreamParams' (OptionalInputStreamParams) member of 'ParentBlobConstructorParams'
09-14 14:02:38.361 I/Gecko (18366): IPDL protocol error: Error deserializing 'BlobConstructorParams'
09-14 14:02:38.361 I/Gecko (18366):
09-14 14:02:38.361 I/Gecko (18366): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x2C0003,name=PContent::Msg_PBlobConstructor) Value error: message was deserialized, but contained an illegal value
09-14 14:02:38.361 I/Gecko (18366):
09-14 14:02:38.411 I/Gecko (18366):
09-14 14:02:38.411 I/Gecko (18366): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
09-14 14:02:38.411 I/Gecko (18366):
09-14 14:02:38.411 I/Gecko (18366):
09-14 14:02:38.411 I/Gecko (18366): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
09-14 14:02:38.411 I/Gecko (18366):
09-14 14:02:38.411 I/Gecko (18366):
09-14 14:02:38.411 I/Gecko (18366): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
09-14 14:02:38.411 I/Gecko (18366):
09-14 14:02:38.411 I/Gecko (18366): [Parent 18366] WARNING: pipe error (136): Connection reset by peer: file ../../../gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 451
09-14 14:02:38.421 I/Gecko (18366):
09-14 14:02:38.421 I/Gecko (18366): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
NB - there is no crash report available.
Test is now disabled: 
https://github.com/mozilla-b2g/gaia/commit/8ed821f81237e52e7eb91bce55f2290a544bf29a

This is blocking QA smoketest automation.
I can reproduce this issue manually on B2G-Inbound

Geko diff http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=c22fbd74e303&tochange=bf5fcc0c4b27

There was no gaia commit between the 2 builds
Component: IPC → DOM: Content Processes
The regression range points to a mozilla inbound merge, so this needs to be bisected on m-i.

Nominating as it's a QA blocker, since it's causing QA automation to permanently fail.
blocking-b2g: --- → 2.2?
Whiteboard: [xfail]
This is bent.
Flags: needinfo?(bent.mozilla)
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #6)
> This is bent.

You mean bug 994190 caused this?
I'm on it.
Flags: needinfo?(bent.mozilla)
Bug 994190 was backed out so resolving WFM.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
blocking-b2g: 2.2? → ---
Hi Gregor, this feature apparently broke even though TBPL remained completely green. Can you find resources to get integration tests added for this so that we don't break you again?
Flags: needinfo?(anygregor)
Can we get an integration test for this use-case?
Flags: needinfo?(kgrandon)
Flags: needinfo?(anygregor)
Flags: in-testsuite?
I believe we have tests for this feature already, but we need OOP b2g desktop or to run these on a real device. Both of which are coming soon.

Once bug 1034504 is solved we should be running these tests on a device. Bug 1001029 should also allow us to catch these on TBPL.

Marking as in-testsuite- until we have these.
Flags: needinfo?(kgrandon)
Flags: in-testsuite?
Flags: in-testsuite-
+1 what kgrandon said. and also need e.me mocked locally instead of using the internet to go to e.me servers.

Although this test exists in the Python suite and is already run on device.
(In reply to Zac C (:zac) from comment #15)
> +1 what kgrandon said. and also need e.me mocked locally instead of using
> the internet to go to e.me servers.
> 
> Although this test exists in the Python suite and is already run on device.

FWIW - we do mock E.me from marionetteJS tests. I'm not sure if there's any way to share this between JS and Python tests, or if we would want to: https://github.com/mozilla-b2g/gaia/blob/master/shared/test/integration/eme_server/parent.js
You need to log in before you can comment on or make changes to this bug.