Closed Bug 1067377 Opened 6 years ago Closed 6 years ago

Removed compatibility layer of libvpx

Categories

(Core :: Audio/Video, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: StMichalke, Unassigned)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 2014091513

Steps to reproduce:

I compiled the latest mozilla-central tree, --with-system-libvpx enabled.


Actual results:

Compilation fails, because the libvpx devs removed the compat layer which mapped the VPX_PLANE_* and VPX_IMG_FMT_* constants introduced in libvpx v0.9.1 to their older counterparts w/o the VPX_ prefix.


Expected results:

There are a few places where Mozilla still uses the old constants. I attached two patches which renames the constants.
Attached patch The 2nd patch.Splinter Review
2nd patch.
Comment on attachment 8489368 [details] [diff] [review]
libvpx_removed_compat-VP8TrackEncoder.patch

Review of attachment 8489368 [details] [diff] [review]:
-----------------------------------------------------------------

Hi! Thanks for the patch submission. Normally you should set the r=? flag with one of the suggested reviewers to get prompt attention.
Attachment #8489368 - Flags: review+
Comment on attachment 8489369 [details] [diff] [review]
The 2nd patch.

Passing review of the webrtc bit to jesup.

Steffan, can you take care of submitting this one upstream as well? This part of the code comes from webrtc.org.
Attachment #8489369 - Flags: review?(rjesup)
Blocks: 1063356
Attachment #8492425 - Flags: review?(kinetik) → review+
I've submitted a bug report @ webrtc.org (#3839). The first two patches should therefore be obsolete as far as I can see, one could wait for a fixed upstream version of webrtc.
No, these should land. We want to update our in-tree copy of libvpx as well, and that will likely happen sooner than a webrtc update. Doing so requires these patches, so thanks for the timely fix!
I also wonder how chromium handles this, since they're using an equally new libvpx.
Attachment #8489369 - Flags: review?(rjesup) → review+
(In reply to Ralph Giles (:rillian) from comment #7)
> I also wonder how chromium handles this, since they're using an equally new
> libvpx.

They are fixing it on their own before it goes upstream with webrtc. Their pritority.
You need to log in before you can comment on or make changes to this bug.