Video is not playing, audio is fine [Aurora]

RESOLVED DUPLICATE of bug 1064847

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1064847
3 years ago
3 years ago

People

(Reporter: karlcow, Unassigned)

Tracking

34 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
0. No Flash with Firefox 34.0a2 (2014-09-16)
1. go to youtube 
2. Play a video.

Expected:
The video to play with the sound.

Actual:
The video is a black screen, the sound is working fine.


On Youtube I have the HTML5 mode activated.
The HTML5 player is started.

On http://www.youtube.com/html5
* Available: HTMLVideoElement, H.264, WebM VP8
* Not available: Media Source Extensions, MSE & H.264, MSE & WebM VP9

The videos are working in Firefox nightly 35.0a1 (2014-09-09), the player is HTML too. The options set is the same.


Some things tried
1. Deactivating Ghostery doesn't change anything
2. Deactivating hardware acceleration doesn't change anything
3. Cookies, Cache, etc doesn't change anything.

If you have other ideas to try, tell me. I'll be happily testing.
(Reporter)

Updated

3 years ago
(Reporter)

Comment 1

3 years ago
Ah yesterday, Nightly was working. This morning it doesn't anymore after updating to 35.0a1 (2014-09-16). Nightly asked me to activate the e10s multiprocess and I said yes.

After resetting Nightly, and NOT accepting multiprocess e10s, the video is working, audio is fine.

One more time to be sure. Resetting Nightly, accepting Multiprocess e10s, video is not working. Audio is fine.


So I can reproduce this consistently.


Application Basics
------------------

Name: Firefox
Version: 35.0a1
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:35.0) Gecko/20100101 Firefox/35.0
Multiprocess Windows: 2/2

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Graphics
--------

Device ID: 0x a26
GPU Accelerated Windows: 2/2 OpenGL (OMTC)
Vendor ID: 0x8086
WebGL Renderer: Intel Inc. -- Intel HD Graphics 5000 OpenGL Engine
windowLayerManagerRemote: true
AzureCanvasBackend: quartz
AzureContentBackend: quartz
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20140916133141
browser.startup.homepage_override.buildID: 20140916133141
browser.startup.homepage_override.mstone: 35.0a1
browser.tabs.remote.autostart: true
dom.mozApps.used: true
extensions.lastAppVersion: 35.0a1
media.gmp-gmpopenh264.lastUpdate: 1408372587
media.gmp-gmpopenh264.path: /Users/karl/Library/Application Support/Firefox/Profiles/9kun6fp5.testingNightly/gmp-gmpopenh264
media.gmp-gmpopenh264.version: 1.0
media.gmp-manager.lastCheck: 1410866565
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1410867337
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1410320743

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.7
Version in use: 4.10.7

NSS
Expected minimum version: 3.17.1 Basic ECC Beta
Version in use: 3.17.1 Basic ECC Beta

NSSSMIME
Expected minimum version: 3.17.1 Basic ECC Beta
Version in use: 3.17.1 Basic ECC Beta

NSSSSL
Expected minimum version: 3.17.1 Basic ECC Beta
Version in use: 3.17.1 Basic ECC Beta

NSSUTIL
Expected minimum version: 3.17.1 Beta
Version in use: 3.17.1 Beta

Experimental Features
---------------------

Comment 2

3 years ago
Looks like bug 1064847 from comment 1. Please un-dup if I'm mistaken.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1064847
(Reporter)

Comment 3

3 years ago
ah thanks cajbir. That seems to nail it indeed!
You need to log in before you can comment on or make changes to this bug.