JSBridge and Mozmill broken due to 'let' changes in bug 1001090

RESOLVED FIXED

Status

P1
critical
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({regression})

Trunk
regression
Dependency tree / graph
Bug Flags:
in-testsuite -

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Currently Mozmill and JSBridge are both broken due to the latest changes for the let statement in bug 1001090. This requires an emergency release of 2.0.8, to get our tests working again for Nightly builds.
(Assignee)

Updated

4 years ago
Assignee: nobody → hskupin
(Assignee)

Comment 1

4 years ago
I also see a couple of other JavascriptWarnings, which actually bubble up as critical framework error in Mozmill. The reason for that behavior is, that our regex also catches 'TypeError'. So I think we should simply update our regex to use '\WError' instead, which would match stand-alone errors.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Created attachment 8489994 [details] [diff] [review]
Fix for let and console listener v1
Attachment #8489994 - Flags: review?(ahalberstadt)
Attachment #8489994 - Flags: review?(ahalberstadt) → review+
(Assignee)

Comment 3

4 years ago
Comment on attachment 8489994 [details] [diff] [review]
Fix for let and console listener v1

Review of attachment 8489994 [details] [diff] [review]:
-----------------------------------------------------------------

Andrei, please get this tested across platforms. Thanks.
Attachment #8489994 - Flags: feedback?(andrei.eftimie)
(Assignee)

Updated

4 years ago
Blocks: 1067950

Comment 4

4 years ago
Comment on attachment 8489994 [details] [diff] [review]
Fix for let and console listener v1

Review of attachment 8489994 [details] [diff] [review]:
-----------------------------------------------------------------

All seems to be working fine.

Regarding the error regex lets hope it won't dismiss anything else we might want to be caught.
Attachment #8489994 - Flags: feedback?(andrei.eftimie) → feedback+
(Assignee)

Comment 5

4 years ago
The cases we know at the moment are covered by tests. So if we would fail in detecting those messages, we should then improve the tests. So far I don't see an obvious fallout.

https://github.com/mozilla/mozmill/commit/95f24c5afa0c7308a1c3d518775378bb1c8d14af (master)
https://github.com/mozilla/mozmill/commit/d753d3ec8ab4a2922b114d9f4c9ede732ddc2378 (hotfix-2.0)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Priority: -- → P1
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.