Closed Bug 1067979 Opened 9 years ago Closed 9 years ago

Intermittent 861958.html | application crashed [@ mozilla::TrackUnionStream::CopyTrackData(mozilla::StreamBuffer::Track *,unsigned int,__int64,__int64,bool *)]

Categories

(Core :: Audio/Video, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1059101

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: crash, intermittent-failure)

Windows XP 32-bit fx-team debug test crashtest on 2014-09-16 06:38:00 PDT for push 04349a090473

slave: t-xp32-ix-067

https://tbpl.mozilla.org/php/getParsedLog.php?id=48196197&tree=Fx-Team

06:42:27  WARNING -  PROCESS-CRASH | file:///C:/slave/test/build/tests/reftest/tests/dom/media/tests/crashtests/861958.html | application crashed [@ mozilla::TrackUnionStream::CopyTrackData(mozilla::StreamBuffer::Track *,unsigned int,__int64,__int64,bool *)]
06:42:27     INFO -  Crash dump filename: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpdsgkfo.mozrunner\minidumps\78f867c1-ec92-4ae3-a2e2-33754f0652f6.dmp
06:42:27     INFO -  Operating system: Windows NT
06:42:27     INFO -                    5.1.2600 Service Pack 3
06:42:27     INFO -  CPU: x86
06:42:27     INFO -       GenuineIntel family 6 model 30 stepping 5
06:42:27     INFO -       8 CPUs
06:42:27     INFO -  Crash reason:  EXCEPTION_BREAKPOINT
06:42:27     INFO -  Crash address: 0x31b473a
06:42:27     INFO -  Thread 52 (crashed)
06:42:27     INFO -   0  xul.dll!mozilla::TrackUnionStream::CopyTrackData(mozilla::StreamBuffer::Track *,unsigned int,__int64,__int64,bool *) [TrackUnionStream.h:04349a090473 : 267 + 0x17]
06:42:27     INFO -      eip = 0x031b473a   esp = 0x14aafd38   ebp = 0x14aafdb8   ebx = 0x0bec6bc0
06:42:27     INFO -      esi = 0x0ebe2908   edi = 0x00037415   eax = 0x00000000   ecx = 0x78abff12
06:42:27     INFO -      edx = 0x78b545b0   efl = 0x00000212
06:42:27     INFO -      Found by: given as instruction pointer in context
06:42:27     INFO -   1  xul.dll!mozilla::TrackUnionStream::ProcessInput(__int64,__int64,unsigned int) [TrackUnionStream.h:04349a090473 : 77 + 0x25]
06:42:27     INFO -      eip = 0x031b4a55   esp = 0x14aafdc0   ebp = 0x14aafe2c
06:42:27     INFO -      Found by: call frame info
06:42:27     INFO -   2  xul.dll!mozilla::MediaStreamGraphImpl::Process(__int64,__int64) [MediaStreamGraph.cpp:04349a090473 : 1334 + 0x14]
06:42:27     INFO -      eip = 0x031b69ca   esp = 0x14aafe34   ebp = 0x14aafe7c
06:42:27     INFO -      Found by: call frame info
06:42:27     INFO -   3  xul.dll!mozilla::MediaStreamGraphImpl::OneIteration(__int64,__int64,__int64,__int64) [MediaStreamGraph.cpp:04349a090473 : 1415 + 0x12]
06:42:27     INFO -      eip = 0x031b6c8e   esp = 0x14aafe84   ebp = 0x14aafebc
06:42:27     INFO -      Found by: call frame info
06:42:27     INFO -   4  xul.dll!mozilla::AudioCallbackDriver::DataCallback(float *,long) [GraphDriver.cpp:04349a090473 : 837 + 0x1b]
06:42:27     INFO -      eip = 0x0318e0d9   esp = 0x14aafec4   ebp = 0x14aaff1c
06:42:27     INFO -      Found by: call frame info
06:42:27     INFO -   5  xul.dll!mozilla::AudioCallbackDriver::DataCallback_s(cubeb_stream *,void *,void *,long) [GraphDriver.cpp:04349a090473 : 725 + 0xd]
06:42:27     INFO -      eip = 0x0318f998   esp = 0x14aaff24   ebp = 0x14aaff2c
06:42:27     INFO -      Found by: call frame info
06:42:27     INFO -   6  gkmedias.dll!winmm_refill_stream [cubeb_winmm.c:04349a090473 : 146 + 0xe]
06:42:27     INFO -      eip = 0x018643f5   esp = 0x14aaff34   ebp = 0x14aaff5c
06:42:27     INFO -      Found by: call frame info
06:42:27     INFO -   7  gkmedias.dll!winmm_buffer_thread [cubeb_winmm.c:04349a090473 : 208 + 0xa]
06:42:27     INFO -      eip = 0x018645ca   esp = 0x14aaff64   ebp = 0x14aaff70
06:42:27     INFO -      Found by: call frame info
06:42:27     INFO -   8  msvcr100.dll + 0x5c6dd
06:42:27     INFO -      eip = 0x78afc6de   esp = 0x14aaff78   ebp = 0x14aaffa8
06:42:27     INFO -      Found by: call frame info
06:42:27     INFO -   9  msvcr100.dll + 0x5c787
Please stop filing dupes of this?
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.