bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

crash in js::jit::LazyLinkTopActivation(JSContext*)

RESOLVED FIXED in mozilla35

Status

()

Core
JavaScript Engine: JIT
--
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: h4writer)

Tracking

({crash})

35 Branch
mozilla35
All
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-1739cc53-a4da-4a67-8c91-2f0652140915.
=============================================================

Updated

4 years ago
Flags: needinfo?(hv1989)
(Assignee)

Comment 1

4 years ago
This is caused by landing of bug 1047346.
Blocks: 1047346
Flags: needinfo?(hv1989)
(Assignee)

Comment 2

4 years ago
Created attachment 8493262 [details] [diff] [review]
Disable lazy linking for arm

Quick fix by disabling lazy linking for ARM temporarily. This is because the arm assembly of the lazy link stub is incorrect (as stated by you in bug 1047346 comment 11). I want to address your comments later this week. (After urgent stuff after week PTO is done). But let us remove this crash source.
Assignee: nobody → hv1989
Attachment #8493262 - Flags: review?(mrosenberg)
(Assignee)

Comment 3

4 years ago
Comment on attachment 8493262 [details] [diff] [review]
Disable lazy linking for arm

Review of attachment 8493262 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jit/Ion.cpp
@@ +1848,5 @@
>          }
>          if (!builder)
>              break;
>  
> +#if defined(JS_CODEGEN_X86) || defined(JS_CODEGEN_X64)

Add comment:

// TODO bug 1047346: Enable lazy linking for other architectures again by fixing the lazy link stub.
Comment on attachment 8493262 [details] [diff] [review]
Disable lazy linking for arm

Review of attachment 8493262 [details] [diff] [review]:
-----------------------------------------------------------------

Seems straightforward enough.
Attachment #8493262 - Flags: review?(mrosenberg) → review+

Comment 6

4 years ago
https://hg.mozilla.org/mozilla-central/rev/0c8fa599e889
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1071068
You need to log in before you can comment on or make changes to this bug.