http://people.mozilla.org/~bgirard/webgl-tweak.html is slower with d3d11 angle than d3d9

RESOLVED DUPLICATE of bug 1076020

Status

()

defect
RESOLVED DUPLICATE of bug 1076020
5 years ago
5 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

My guess is this is because of the difference in how uniform updates are implemented. With D3D9 uniform updates are done with SetVertexShaderConstantF etc. with D3D11 than are done with Map/Unmap on a constant buffer. IE11 does them with UpdateSubresource instead of Map/Unmap and I expect that this might put the update in the command stream (which I assume is what d3d9 does) instead of in a temporary buffer.
Blocks: 912196
Blocks: 1066312
I want to be able to change the demo. I'm uploading the copy at the time of the filing. We should test against this version and not the version on my people which I will change from time to time.
Chrome Canary with D3D11 has fixed this performance problem. Shipping Chrome still has the performance problem:

This suggests the improvement happened between f4126d2b9eb0 and bbffd5562e33
Blocks: 1079398
This looks like it is basically an angle update
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1076020
You need to log in before you can comment on or make changes to this bug.