Closed Bug 1068369 Opened 10 years ago Closed 10 years ago

"Add-on Update Checker" add-on does not work with e10s

Categories

(Firefox :: Extension Compatibility, defect)

35 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 35
Tracking Status
e10s + ---

People

(Reporter: anvaliar, Unassigned)

References

()

Details

(Keywords: addon-compat)

Attachments

(1 file)

Tested with win 7 x64 | Nightly 35.0a1 (2014-09-16)
tracking-e10s: --- → ?
Keywords: addon-compat
Attached file Error log
The developer has been notified through AMO.
This was fixed 2 months ago (2.8beta).  I'm not sure the breakage was actually e10s related.  The problem was the add-on was no longer able to read preferences.  I was using 'UAPref = Components.classes["@mozilla.org/preferences-service;1"].getService(Components.interfaces.nsIPrefService);' in a function and it stopped working there.  If I moved it outside of functions it started working again.  (This also broke a few other extensions I happen to be running that I fixed the same way.)  I finally settled on using 'let UAPref = Services.prefs;' in its place and it works in functions again.
(In reply to Chris from comment #3)
> This was fixed 2 months ago (2.8beta).

Thanks, Chris! Add-on Update Checker 2.8 is now on AMO.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: