If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Puzzle Toolbars" (formerly "The Puzzle Piece") add-on does not work with e10s

RESOLVED FIXED

Status

()

Firefox
Extension Compatibility
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Valiar, Unassigned)

Tracking

({addon-compat})

35 Branch
x86_64
Windows 7
addon-compat
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(URL)

Attachments

(1 attachment)

18.06 KB, text/plain
Details
(Reporter)

Description

3 years ago
Tested with win 7 x64 | Nightly 35.0a1 (2014-09-16)
(Reporter)

Updated

3 years ago
tracking-e10s: --- → ?
Keywords: addon-compat
Hardware: x86 → x86_64
Blocks: 905436
tracking-e10s: ? → +
hi Luís, your Puzzle Piece add-on seems to be broken with multiprocess Firefox (e10s). If you have any questions about e10s support, just drop by the #e10s IRC channel on irc.mozilla.org. MDN also has a good introduction:

https://developer.mozilla.org/en-US/Add-ons/Working_with_multiprocess_Firefox
The latest beta version (1.4b*) in the development channel should already work fine in e10s. Just haven't released it yet because there's a few more bugs to fix and new features I want to implement for the next version, which I'm already working on. So, should be soon.
Awesome! Thanks, Luís.

I'll leave this Firefox bug open as a reminder for the e10s team to test the new version.
(Reporter)

Comment 4

3 years ago
Created attachment 8490679 [details]
Error log
(In reply to Valiar from comment #4)
> Created attachment 8490679 [details]
> Error log

I believe that is for Video Resumer, not The Puzzle Piece.
(Reporter)

Comment 6

3 years ago
I attached error log with all my addons switched on just to check if everything going right with "Puzzle 1.4b" 

Previously I thought that FT DeepDark 11.3.1 (https://addons.mozilla.org/en-US/firefox/addon/ft-deepdark/) has incompatibility with Puzzle,but nothing happens with the native skin as well.
The new version of Puzzle Toolbars (The Puzzle Piece) has been approved and is now publicly available. It is (or should be) completely compatible with e10s.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Summary: "The Puzzle Piece" add-on does not work with e10s → "Puzzle Toolbars" (formerly "The Puzzle Piece") add-on does not work with e10s
Awesome! Thanks, Luís. :)
You need to log in before you can comment on or make changes to this bug.