Closed Bug 1068442 Opened 7 years ago Closed 7 years ago

Add marionette test for SHB on secure window

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S5 (26sep)
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

Opening this bug to track the attempt at adding a marionette test to check visibility of the SHB on a secure fullscreen window.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Whiteboard: [systemsfe]
Target Milestone: --- → 2.1 S5 (26sep)
Attached file Github pull request
Comment on attachment 8490841 [details] [review]
Github pull request

Alive - I'd like you to take a look at this if you have the time. This patch allows us to enable the SHB on desktop so we can write marionette tests against it. Mobile devices will still turn it on by default if they do not have a hardware button, and the desktop client can enable it by toggling the setting.
Attachment #8490841 - Flags: review?(alive)
Comment on attachment 8490841 [details] [review]
Github pull request

The 'secure window' is confusing me because we have a SecureWindow class. But this looks fine I think.
Attachment #8490841 - Flags: review?(alive) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/b3d5258dfa82225beff03bc8b294b8660aaef95d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1082797
Comment on attachment 8490841 [details] [review]
Github pull request

Fabrice - wondering if we can get this into v2.1. We currently have several failing software home button tests on the v2.1 branch because this never made it to that branch. This commit allows us to test the software home button against the v2.1 branch by modifying some checks in the system app. Before the system app would not allow you to turn on the software home button on desktop, this changes that. 

I would like to see this uplifted as the software home button is an important part of v2.1, and without this we have no way of knowing if we are breaking things.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Original implementation.
[User impact] if declined: No user impact, but may help us ship a more stable, tested product.
[Testing completed]: This was only for tests, and is almost a=testonly, but there is two lines of code that were modified to support these tests.
[Risk to taking this patch] (and alternatives if risky): I think this is extremely low risk.
[String changes made]: None.
Attachment #8490841 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8490841 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
You need to log in before you can comment on or make changes to this bug.