Closed Bug 1068526 Opened 5 years ago Closed 5 years ago

MacBook touchpad not scrolling with two fingers when e10s enabled

Categories

(Firefox :: General, defect)

35 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 863514

People

(Reporter: merihakar, Unassigned)

Details

If I enable e10s, I am unable to scroll the page with two finger gesture. Text selection/moving with three fingers works fine.

System Info:
MacBook Pro
13-inch, Mid 2012
Processor  2,9 GHz Intel Core i7
Memory  16 GB 1600 MHz DDR3
Graphics  Intel HD Graphics 4000
Software  OS X 10.9.4 (13E28)
I have the exact same computer/software and am unable to reproduce this on Nightly 35.0a1.

Do you have any touchpad "augmentation" software, such as BetterTouchTool, enabled and configured in a way that might conflict with Firefox?
I have no extra software installed. I've tried with last Nightly (35.0a1 (2014-09-18)) and as soon as I enable e10s, I am unable to scroll. One interesting thing is, I can scroll inside about:preferences page.

This is my work computer, I will also try at home and tell if I can scroll.
The fact that it works on the settings page (where most extensions are disabled) points to an extension issue. Try resetting Firefox (Help menu -> Troubleshooting Information -> Reset) and let us know if that fixes it.
I do not have any extensions installed in Nightly.

I can scroll inside: about:preferences, about:addons, about:support
I cannot scroll inside: about:config, any other webpage.

I also cannot scroll horizontally, and navigate on history with swipe gesture (e10s enabled or not).

I do not know if they are related or not but, I have these flags enabled in about:config :


>layout.css.filters.enabled
>layout.css.outline-style-auto.enabled
>layout.css.overflow-clip-box.enabled
>layout.css.ruby.enabled
>layout.css.scroll-behavior.enabled
>layout.css.text-align-true-value.enabled
>layout.css.touch_action.enabled
>layout.css.vertical-text.enabled
>layout.css.will-change.enabled
>layout.css.grid.enabled
>
>canvas.customfocusring.enabled
>canvas.hitregions.enabled
>
>media.eme.enabled
>media.fragmented-mp4.exposed
>media.mediasource.enabled
>media.peerconnection.video.h264_enabled
>media.webspeech.recognition.enable
>media.webspeech.synth.enable
>media.webvtt.regions.enabled
>
>dom.experimental_forms
>dom.forms.autocomplete.experimental
>dom.forms.requestAutocomplete
>dom.webcomponents.enabled
>dom.serviceWorkers.enabled
>dom.image.picture.enabled
>dom.image.srcset.enabled
>dom.enable_resource_timing
>dom.w3c_pointer_events.enabled
>dom.netinfo.enabled
>
>security.csp.experimentalEnabled
>
>svg.new-getBBox.enabled
>
>layers.async-pan-zoom.enabled
>devtools.storage.enabled
Found! layers.async-pan-zoom.enabled preference prevents vertical scrolling if e10s enabled and prevents horizontal scrolling/history back-forward no matter what.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 863514
You need to log in before you can comment on or make changes to this bug.