Closed Bug 1068544 Opened 5 years ago Closed 5 years ago

Support transceive function for nfcd

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.2+, tracking-b2g:+, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S5 (26sep)
feature-b2g 2.2+
tracking-b2g +
Tracking Status
b2g-v2.2 --- fixed

People

(Reporter: dimi, Assigned: dimi)

References

Details

(Whiteboard: [priority])

Attachments

(2 files, 1 obsolete file)

For proprietary tag information exchange, nfcd should support transceive function to transfer data
Attached patch WIP Patch v1 (obsolete) — Splinter Review
For MWC demo
tracking-b2g: --- → +
Whiteboard: [priority]
Blocks: 1109456
Attachment #8533601 - Attachment is obsolete: true
Attachment #8539948 - Flags: review?(allstars.chh)
Comment on attachment 8539948 [details] [review]
pull request to mozilla-b2g/platform_system_nfcd v2

see github.
Attachment #8539948 - Flags: review?(allstars.chh)
(In reply to Yoshi Huang[:allstars.chh] from comment #4)
> Comment on attachment 8539948 [details] [review]
> pull request to mozilla-b2g/platform_system_nfcd v1
> 
> see github.

Hi Yoshi,
I have answered some questions in github, could you check it again ?
Thanks.
Flags: needinfo?(allstars.chh)
replied
Flags: needinfo?(allstars.chh)
Comment on attachment 8539948 [details] [review]
pull request to mozilla-b2g/platform_system_nfcd v2

- Address comment
- add notifyRfTimeout function
- change transceive function to use vector for both input and output parameter
Attachment #8539948 - Attachment description: pull request to mozilla-b2g/platform_system_nfcd v1 → pull request to mozilla-b2g/platform_system_nfcd v2
Attachment #8539948 - Flags: review?(allstars.chh)
Attachment #8539948 - Flags: review?(allstars.chh) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Comment on attachment 8539948 [details] [review]
pull request to mozilla-b2g/platform_system_nfcd v2

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
NFC feature

User impact if declined: 
Third party Apps can not use NFC transceive function to get information
from tag

Testing completed: 
Manually.

Risk to taking this patch (and alternatives if risky): 
No.

String or UUID changes made by this patch:
No.
Attachment #8539948 - Flags: approval-mozilla-b2g37?
Attachment #8539948 - Flags: approval-mozilla-b2g37?
feature-b2g: --- → 2.2+
You need to log in before you can comment on or make changes to this bug.