Closed Bug 1068611 Opened 8 years ago Closed 8 years ago

[Contacts] [Regression] When importing contacts from Gmail the last imported date is not updated

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S5 (26sep)
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: jmcf, Assigned: crdlc)

Details

Attachments

(1 file)

STR:

Contacts -> Settings --> Import from Gmail --> SucessFully Import.

Actual: The last imported date is not refreshed

Expected: Date is refreshed

Note: The date is refreshed if the Contacts app is killed and then repopen
Can you ask for a regression window?

Also knowing which version are affected will be nice.
Stealing here Jose ;) Gracias
Assignee: jmcf → crdlc
Status: NEW → ASSIGNED
Attached file Github pull request
Attachment #8490792 - Flags: review?(jmcf)
Comment on attachment 8490792 [details]
Github pull request

r+ provided tests pass on TBPL

thanks!
Attachment #8490792 - Flags: review?(jmcf) → review+
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #1)
> Can you ask for a regression window?
> 
> Also knowing which version are affected will be nice.

QA can confirm whether this reproduces on 2.1 or not
Keywords: qawanted
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/d32d647028a8eb5aed5583e9bab6ffcd63f38626
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Tested and *not* working, contacts are imported I can see last imported date *only* when user closes Contacts settings and accesses again.

Flame 
2.2
User
Gecko
Gaia
(In reply to Loli (:lolimartinezcr) from comment #7)
> Tested and *not* working, contacts are imported I can see last imported date
> *only* when user closes Contacts settings and accesses again.
> 
> Flame 
> 2.2
> User
> Gecko
> Gaia

Loli, are you sure you are testing with latest master build?
(In reply to Jose Manuel Cantera from comment #8)
> (In reply to Loli (:lolimartinezcr) from comment #7)
> > Tested and *not* working, contacts are imported I can see last imported date
> > *only* when user closes Contacts settings and accesses again.
> > 
> > Flame 
> > 2.2
> > User
> > Gecko
> > Gaia
> 
> Loli, are you sure you are testing with latest master build?

Gecko cce3dff
Gaia 31434a3
Platform version: 35.0a1
Build ID: 20140918075610
Git commit: 879bd62d
My commit is more recent than 879bd62d
Tested and working
Flame
2.2
Gecko-93e8d33
Gaia-dbc8904
Status: RESOLVED → VERIFIED
Comment on attachment 8490792 [details]
Github pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: wrong last date after importing from FB or Gmail
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): close to null
[String changes made]: no
Attachment #8490792 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8490792 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Yeojin, can you verify this on 2.1?
Flags: needinfo?(ychung)
This issue is verified on 2.1. The date is updated correctly after importing Gmail contacts:

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141002000202
Gaia: 94dcc25f2e34a4900ea58310c26be52bcb089161
Gecko: baaa0c3ab8fd
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ychung) → needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.